Support » Networking WordPress » MultiSite–>All Admins cannot login (normal users can)

Viewing 10 replies - 1 through 10 (of 10 total)
  • So my guess is that there is a memory issue… Did you recently make any changes ie. installing new plugins or add more sites?

    Iยดm thinking that loading the admin user takes up to much PHP memory and therefore times out…

    Can you get to the PHP.ini and increasing the memory limit?

    Hi wpfranner, thanks for the response.

    I had upped my php.ini, here’s a cut-paste of it:

    ;;; DreamHost-generated php.ini for PHP 54
    
    allow_call_time_pass_reference = 0
    asp_tags = 0
    date.timezone = "America/Los_Angeles"
    display_errors = 1
    engine = 1
    error_reporting = E_ALL & ~E_NOTICE
    expose_php = 0
    include_path = ".:/usr/local/lib/php:/usr/local/php5/lib/pear"
    magic_quotes_gpc = 0
    mail.add_x_header = 1
    memory_limit = "90M"
    output_buffering = 0
    post_max_size = "7M"
    realpath_cache_size = "128k"
    realpath_cache_ttl = 300
    register_argc_argv = 0
    register_globals = 0
    register_long_arrays = 0
    safe_mode = 0
    session.bug_compat_42 = 0
    session.gc_divisor = 1000
    session.hash_bits_per_character = 6
    session.save_path = "/tmp"
    short_open_tag = 1
    suhosin.cookie.encrypt = 0
    suhosin.session.encrypt = 0
    suhosin.upload.disallow_elf = 0
    upload_max_filesize = "7M"
    xcache.size = "16M"

    EDIT: I AM getting end of premature end of script headers. I’ll need to look into this (sorry I had looked in the wrong log folder).

    Also, I had disabled the plugins my renaming their DIRs temporarily (XXplugins/), (XXmu-plugins/)

    Any other ideas?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    ๐Ÿณ๏ธโ€๐ŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    All of a sudden 4 days ago, I could not login to the Admin panel (as Super Admin). I’m on PHP 5.4, WP 3.6.

    So what’s changed recently? ๐Ÿ™‚

    You know I have to ask that, right?

    Also what does the multisite section of your wp-config.php look like?

    Did you try with the main site using a default theme?

    Also when you disabled your plugins, did you ALSO flip the .htaccess back at the same time? Lots of plugins, esp caching ones, will hang around there.

    Hi Ipstenu,

    From memory, nothing changed. I hadn’t installed any new plugins. I was in the Admin Panel, grabbed a bite, came back 20 minutes later, I tried to get to a new part of the Admin Menu, and I got the waiting–>404 problem
    –> Immediately tested another blog, same symptom.

    Theme –>
    Yes, I change the name of my theme (to force a reversion to default), and no change. I also tested the problem on 3 separate themes-sites, and same symptom.

    htaccess + plugin
    I tried reverting the htaccess, and renaming plugin/mu-plugin DIRs at same time. No joy.

    Here’s what I had in htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I got these errors (I commented them out using @)

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'redirect_to_mapped_domain' not found or invalid function name in /home/CENSORED/main/wp-includes/plugin.php on line 406
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/CENSORED/main/wp-includes/plugin.php:406) in /home/CENSORED/main/wp-includes/pluggable.php on line 875

    Result is a blank screen and this in error log:

    [Wed Sep 04 16:09:19 2013] [error] [client CENSORED] Premature end of script headers: index.php
    [Wed Sep 04 16:13:49 2013] [error] [client CENSORED] Premature end of script headers: wp-login.php, referer: http://CENSORED.com/wp-login.php

    My wp-config
    For security I keep it outside the web dir (one dir above), but I tried moving it back and no joy.

    here’s what /home/username/web/wp-config.php:

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
        define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Location of your WordPress configuration. */
    require_once(ABSPATH . '../wp-config.php');

    here’s what /home/username/wp-config.php looks like (censored of personal info:

    <?php define('WP_CACHE', true);  //
    
    // ** MySQL settings ** //
    define('DB_NAME', 'CENSORED');    // The name of the database
    define('DB_USER', 'CENSORED');     // Your MySQL username
    define('DB_PASSWORD', 'CENSORED'); // ...and password
    define('DB_HOST', 'CENSORED');    // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    define('WP_ALLOW_MULTISITE', true);
    define('WP_POST_REVISIONS', false);
    $base = '/';
    
    // define('DOMAIN_CURRENT_SITE', 'yourdomain.tld');     //commmented out for now b/c interfereing with Multisite plugin
    define('PATH_CURRENT_SITE', '/');
    define('BLOGID_CURRENT_SITE', '1');
    
    // double check $base
    if( $base == 'BASE' )
    	die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix  = 'CENSORED';   // Only numbers, letters, and underscores please!
    
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    
    define( "WP_USE_MULTIPLE_DB", false );
    define(ENABLE_CACHE, true);  // Enable the WordPress Object Cache:
    define('SECRET_KEY', 'CENSORED');
    define('SECRET_SALT', 'CENSORED');
    define( 'LOGGED_IN_KEY', 'CENSORED' );
    define( 'LOGGED_IN_SALT', 'CENSORED' );
    define( 'AUTH_KEY', 'CENSORED' );
    define( 'SECURE_AUTH_KEY', 'CENSORED' );
    define( 'SECURE_AUTH_SALT', CENSORED' );
    define('NONCE_KEY',       'CENSORED');
    define( 'NONCE_SALT', 'CENSORED' );
    define( 'AUTH_SALT', 'CENSORED' );
    define( 'SUNRISE', 'on' );
    define('SAVEQUERIES', true); // works with Debug Queries plugin
    
    // ========================DONT EDIT BELOW HERE========================//
    /* That's all, stop editing! Happy blogging. */
    
    define('ABSPATH', dirname(__FILE__).'/');
    
    // Fixes a WP version 3.5 release issue, where media uploader not working in Chrome
    define('CONCATENATE_SCRIPTS', false );
    
    require_once(ABSPATH.'wp-settings.php');

    Added Note:
    Had the issue 4 days ago, DH tech told me to up my VPS RAM, I did, but the machine broke while upping (separate issue), so they moved me to a new machine 2 days ago. Was able to access Admin Panel for a few hours after they moved me (thought it was fixed). Then suddenly – again – it stopped working on the NEW machine.

    – The problem seems to occur suddenly, and without any software/plugin changes on my part.

    sorry – double post….

    Just trying something…
    Try increasing the memory_limit in php.ini to something BIG – like 512M – remember to restart the Apache after.

    Take a look at this: http://hakre.wordpress.com/2010/08/17/mysteries-about-the-wordpress-memory-limit/

    Thanks wpfranner. I’ve upped it to 256M and also increased by xcache.size to 64M.

    I’d go to 512M but in the article it said it may cause additional errors, so just to be safe I went with the amount they recommended.

    I will be back to post the results after I get up in the morning (it’s 3am now).

    The memory limit increase did not fix the issue, but Dreamhost did something in server configs and fixed it. I tried to get details, but could not.

    I’m still leaving this open for a few days, as the problem did arise out of the blue, so it may do so again.

    Ha! Ipstenu works at Dreamhost… maybe she did a bit’o magic for you ๐Ÿ™‚ Nice to hear you are up and running!

    Thanks for the help wpfranner.

    I’m going to chock this up to a networking failure on DH’s part.

    But they fixed something and it seems to work now.

    In any case, I left my mem limit at 256.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘MultiSite–>All Admins cannot login (normal users can)’ is closed to new replies.