Support » Plugin: Magic Fields 2 » Multisite, "activate_plugins" capability stops ordinary admins from using plugin

  • ade11

    (@ade11)


    In main.php, line #125 or thereabouts, we note you draw the menu with ‘activate_plugins’ capability required.

    In WP Multisite, this is often turned off for site admins, only super-admin has that capability.

    This means that on our multisite setup, our editors and admins cannot use your plugin.

    Please can you fix this as soon as possible?

    Many thanks!!

    http://wordpress.org/plugins/magic-fields-2/

Viewing 1 replies (of 1 total)
  • To add to this, basically all the menu options (except the “import”, for some reason) are being drawn with the wrong capabilities for multisite use.

    Administrators and Editors need to be able to change the plugin’s options, “manage_options” and “activate_plugins” are the ones used currently, on multisite that means only super-admins have access.

    In our case (and probably most others) super admins manage the network, not individual sites, individual sites have ordinary administrators or editors.

    This is an extremely simple fix, please can you incorporate it into the next update?

Viewing 1 replies (of 1 total)
  • The topic ‘Multisite, "activate_plugins" capability stops ordinary admins from using plugin’ is closed to new replies.