Support » Networking WordPress » Multisite 404 error

  • Resolved lindseybugbee



    I’ve had a blog at for a few months now. I decided to create a new site and operate it under the Multisite framework. I set the wildcard DNS subdomain and installed the multisite system; however, I can’t access the child site at all.

    My host is Bluehost. I talked to them and they told me it’s not a server issue.

    Here is what my .htaccess looks like (the big bulk of it is for W3Cache:

    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	RewriteCond %{HTTP_HOST} ^$ [NC]
    	RewriteRule ^(.*)$$1 [R=301,L]
    # Use PHP5 Single php.ini as default
    AddHandler application/x-httpd-php5s .php
    DirectoryIndex index.php index.html index.htm default.htm
    ErrorDocument 404 /?p=404
    ErrorDocument 403 /?p=404
    Redirect 301 /how-to-create-watercolor-flowers-tutorial
    Redirect 301 /about
    # BEGIN W3TC Browser Cache
    <IfModule mod_mime.c>
        AddType text/css .css
        AddType text/x-component .htc
        AddType application/x-javascript .js
        AddType application/javascript .js2
        AddType text/javascript .js3
        AddType text/x-js .js4
        AddType text/html .html .htm
        AddType text/richtext .rtf .rtx
        AddType image/svg+xml .svg .svgz
        AddType text/plain .txt
        AddType text/xsd .xsd
        AddType text/xsl .xsl
        AddType text/xml .xml
        AddType video/asf .asf .asx .wax .wmv .wmx
        AddType video/avi .avi
        AddType image/bmp .bmp
        AddType application/java .class
        AddType video/divx .divx
        AddType application/msword .doc .docx
        AddType application/ .eot
        AddType application/x-msdownload .exe
        AddType image/gif .gif
        AddType application/x-gzip .gz .gzip
        AddType image/x-icon .ico
        AddType image/jpeg .jpg .jpeg .jpe
        AddType application/json .json
        AddType application/ .mdb
        AddType audio/midi .mid .midi
        AddType video/quicktime .mov .qt
        AddType audio/mpeg .mp3 .m4a
        AddType video/mp4 .mp4 .m4v
        AddType video/mpeg .mpeg .mpg .mpe
        AddType application/ .mpp
        AddType application/x-font-otf .otf
        AddType application/vnd.oasis.opendocument.database .odb
        AddType application/vnd.oasis.opendocument.chart .odc
        AddType application/vnd.oasis.opendocument.formula .odf
        AddType application/ .odg
        AddType application/vnd.oasis.opendocument.presentation .odp
        AddType application/vnd.oasis.opendocument.spreadsheet .ods
        AddType application/vnd.oasis.opendocument.text .odt
        AddType audio/ogg .ogg
        AddType application/pdf .pdf
        AddType image/png .png
        AddType application/ .pot .pps .ppt .pptx
        AddType audio/x-realaudio .ra .ram
        AddType application/x-shockwave-flash .swf
        AddType application/x-tar .tar
        AddType image/tiff .tif .tiff
        AddType application/x-font-ttf .ttf .ttc
        AddType audio/wav .wav
        AddType audio/wma .wma
        AddType application/ .wri
        AddType application/ .xla .xls .xlsx .xlt .xlw
        AddType application/zip .zip
    <IfModule mod_expires.c>
        ExpiresActive On
        ExpiresByType text/css A691200
        ExpiresByType text/x-component A691200
        ExpiresByType application/x-javascript A691200
        ExpiresByType application/javascript A691200
        ExpiresByType text/javascript A691200
        ExpiresByType text/x-js A691200
        ExpiresByType text/html A691200
        ExpiresByType text/richtext A691200
        ExpiresByType image/svg+xml A691200
        ExpiresByType text/plain A691200
        ExpiresByType text/xsd A691200
        ExpiresByType text/xsl A691200
        ExpiresByType text/xml A691200
        ExpiresByType video/asf A691200
        ExpiresByType video/avi A691200
        ExpiresByType image/bmp A691200
        ExpiresByType application/java A691200
        ExpiresByType video/divx A691200
        ExpiresByType application/msword A691200
        ExpiresByType application/ A691200
        ExpiresByType application/x-msdownload A691200
        ExpiresByType image/gif A691200
        ExpiresByType application/x-gzip A691200
        ExpiresByType image/x-icon A691200
        ExpiresByType image/jpeg A691200
        ExpiresByType application/json A691200
        ExpiresByType application/ A691200
        ExpiresByType audio/midi A691200
        ExpiresByType video/quicktime A691200
        ExpiresByType audio/mpeg A691200
        ExpiresByType video/mp4 A691200
        ExpiresByType video/mpeg A691200
        ExpiresByType application/ A691200
        ExpiresByType application/x-font-otf A691200
        ExpiresByType application/vnd.oasis.opendocument.database A691200
        ExpiresByType application/vnd.oasis.opendocument.chart A691200
        ExpiresByType application/vnd.oasis.opendocument.formula A691200
        ExpiresByType application/ A691200
        ExpiresByType application/vnd.oasis.opendocument.presentation A691200
        ExpiresByType application/vnd.oasis.opendocument.spreadsheet A691200
        ExpiresByType application/vnd.oasis.opendocument.text A691200
        ExpiresByType audio/ogg A691200
        ExpiresByType application/pdf A691200
        ExpiresByType image/png A691200
        ExpiresByType application/ A691200
        ExpiresByType audio/x-realaudio A691200
        ExpiresByType image/svg+xml A691200
        ExpiresByType application/x-shockwave-flash A691200
        ExpiresByType application/x-tar A691200
        ExpiresByType image/tiff A691200
        ExpiresByType application/x-font-ttf A691200
        ExpiresByType audio/wav A691200
        ExpiresByType audio/wma A691200
        ExpiresByType application/ A691200
        ExpiresByType application/ A691200
        ExpiresByType application/zip A691200
    <IfModule mod_deflate.c>
        <IfModule mod_headers.c>
            Header append Vary User-Agent env=!dont-vary
            AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
        <IfModule mod_mime.c>
            # DEFLATE by extension
            AddOutputFilter DEFLATE js css htm html xml
    <FilesMatch "\.(css|htc|js|js2|js3|js4|CSS|HTC|JS|JS2|JS3|JS4)$">
        FileETag MTime Size
        <IfModule mod_headers.c>
            Header set Pragma "public"
            Header append Cache-Control "public"
             Header unset Set-Cookie
             Header set X-Powered-By "W3 Total Cache/"
    <FilesMatch "\.(html|htm|rtf|rtx|svg|svgz|txt|xsd|xsl|xml|HTML|HTM|RTF|RTX|SVG|SVGZ|TXT|XSD|XSL|XML)$">
        FileETag MTime Size
        <IfModule mod_headers.c>
            Header set Pragma "public"
            Header append Cache-Control "public"
             Header set X-Powered-By "W3 Total Cache/"
    <FilesMatch "\.(asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|eot|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|json|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|otf|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|svg|svgz|swf|tar|tif|tiff|ttf|ttc|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip|ASF|ASX|WAX|WMV|WMX|AVI|BMP|CLASS|DIVX|DOC|DOCX|EOT|EXE|GIF|GZ|GZIP|ICO|JPG|JPEG|JPE|JSON|MDB|MID|MIDI|MOV|QT|MP3|M4A|MP4|M4V|MPEG|MPG|MPE|MPP|OTF|ODB|ODC|ODF|ODG|ODP|ODS|ODT|OGG|PDF|PNG|POT|PPS|PPT|PPTX|RA|RAM|SVG|SVGZ|SWF|TAR|TIF|TIFF|TTF|TTC|WAV|WMA|WRI|XLA|XLS|XLSX|XLT|XLW|ZIP)$">
        FileETag MTime Size
        <IfModule mod_headers.c>
            Header set Pragma "public"
            Header append Cache-Control "public"
             Header unset Set-Cookie
             Header set X-Powered-By "W3 Total Cache/"
    # END W3TC Browser Cache
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    	RewriteEngine On
    	RewriteBase /
    	RewriteRule ^index\.php$ - [L]
    	# add a trailing slash to /wp-admin
    	RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    	RewriteCond %{REQUEST_FILENAME} -f [OR]
    	RewriteCond %{REQUEST_FILENAME} -d
    	RewriteRule ^ - [L]
    	RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    	RewriteRule ^(.*\.php)$ $1 [L]
    	RewriteRule . index.php [L]
    # END WordPress

    The relevant part of wp-config.php looks like this:

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', '');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    Like I said, Bluehost told me that the issue was not their servers. They didn’t change anything at all and just said they couldn’t help me. I don’t know if I should believe them though. The lady I spoke to said that my issue could be that I wrote /* WordPress Multisite */ instead of /* Multisite */ at the beginning of the code (really).

    If Bluehost is right, and everything on their end is fine, do you have any other ideas on what could be causing this? Do you see anything wrong with my files?

    I couldn’t access my site without typing www. in the address bar, it would just redirect me to the login page. I added a redirect rule at the beginning of .htaccess and I wonder if this could be causing the issue.

    Any help is welcome! Thanks!


Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Well, start with turning off and removing the caching plugin, just to rule that out.

    Is the whole subdomain a 404? I think wildcard DNS isn’t right, since is a ‘Chrome cannot find…’ page.

    Sorry, I did not see the new comment until now.

    I gave up temporarily with the Multisite feature.

    Eventually, we migrated to a VPS and made a fresh WordPress install. We tried to install Multisite again and it worked this time.

    To be honest, I have no idea what changed so far. The only difference I spot is that in the VPS define(‘DOMAIN_CURRENT_SITE’, ‘’); was set to define(‘DOMAIN_CURRENT_SITE’, ‘’); instead.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Multisite 404 error’ is closed to new replies.