Support » Plugin: Autoptimize » Multisite?

Viewing 8 replies - 16 through 23 (of 23 total)
  • Plugin Author Frank Goossens

    (@futtta)

    heartbeat should not matter. gzip-stuff in .htaccess neither, as that typically only is done (by Apache) after PHP finished (so AO would not be bothered with that) …

    Plugin Author Frank Goossens

    (@futtta)

    I removed all debug output from the gist linked above and added code to check if the $content passed through the output buffer is gzipped and if so, unzips it.

    All of this based on the “content encoding error” with the previous debug-version, which can only be explained by the content being gzipped when AO receives it from the output buffer (which also explains why AO doesn’t do anything with in the first place).

    Can you give https://gist.github.com/futtta/10373800354595e3f395 a go? 🙂

    Plugin Author Frank Goossens

    (@futtta)

    Updated the gist some more as the content can be gzipped with and without a gzip header (gzencode vs gzcompress), so I test for both now. Keeping my fingers crossed 😉

    Hi Frank,

    Sorry, still no luck… Again, I tried every combination but as soon as I tick one box I get the Content Encoding Error. The only difference this time is, it says it has Cached 8 styles and scripts on the sub pages.

    I really appreciate the time and effort you put in to help me but I think you have done enough. Thanks a lot. I kept your new AO file and unchecked all the boxes except on the main page. I think we should leave it like that. I’m starting to feel very bad for taking your time.
    If you stumble across a solution by chance, please let me know.

    Regards Thomas

    Plugin Author Frank Goossens

    (@futtta)

    I really appreciate the time and effort you put in to help me but I think you have done enough.

    well … it’s a challenge and I do like a small challenge now and again 😉

    I tried every combination but as soon as I tick one box I get the Content Encoding Error. The only difference this time is, it says it has Cached 8 styles and scripts on the sub pages.

    That’s great news actually; this means AO now could make sense of the HTML it got from the output buffer and was able to extract, aggregate & minify the CSS and/or JS.

    The fact that you still have “content encoding error” is probably due to the fact that the code in the GIST didn’t re-compress the HTML after optimizing. I’ve reworked the code to recompress the HTML before returning it to the output buffer, curious if this solves your woes.

    frank

    tada, you made it!!! Frank you’re a genius.

    It’s working perfectly on all sub-pages now and has improved the grades at GTmetrix, especially the YSlow grade (from 84% to 92%). I still need to optimise the page speed a little bit but I’ll get there.

    Many thanks for all your support… 5 stars for you 🙂

    Cheers
    Thomas

    Plugin Author Frank Goossens

    (@futtta)

    It’s working perfectly on all sub-pages now

    Fantastic!!

    Now I’ll have to see if and how i can integrate this into AO proper.

    But this means something (a plugin, probably) is indeed gzencoding the content of the sub-sites, but not the main site. If you ever have time to dive in to that to identify the culprit …

    frank

    Hi Frank, I don’t know if I’ll ever have the time or more importantly the knowledge to figure that out, but when I do I’ll let you know, for sure.
    What really puzzles me at the moment is the Google PageSpeed Insights. It has dropped dramatically and GTmetrix has improved… funny.
    Anyway, thanks again for your fantastic support 🙂
    Cheers
    Thomas

Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘Multisite?’ is closed to new replies.