Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Multiselect not saving multiple selections

  • Hi, this is a great plugin but I am having a problem with multi-select.

    Multiselect works on registration and profile update. It’s saving the correct data in the database, I know this as I have checked … but when I try to update a profile, it strips out all the previously saved multi-selected data on the page and only shows 1 input, not multiple selected items even though they are saved in the database. If I update the page without re-adding my previously multi-selected items, it keeps the 1 item it is displaying and strips the others out the database.

    Whenever I have updated my profile, I have to re-select all my previously multi-selected items, or I will lose them on the update of my profile.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @sim2k,

    This issue may be caused by some conflicts with your theme or other plugins.
    Can you please try to do a conflict test so we can rule out theme/plugin conflicts and see if this issue goes away. Here is the doc on how t do a conflict test if you are not sure how to do it.

    Regards.

    I’ve checked, it does not seem to be a plugin clash.

    I’m using this code to create the dropdown:

    function FormGetGenres() {
    
    $genres = [
    12542 =>'Fantasy 001',
    12543 =>'Fantasy 002',
    12745 =>'Fantasy 003',
    12746 =>'Fantasy 004',
    12544 => 'Urban Fantasy 001',
    12545 => 'Urban Fantasy 002'
    ];
    
    return $genres;
    
    }

    … and in the form setup/creation, I call it in the form setup using “choices for callback” using “FormGetGenres” to pull the details in.

    It shows the drop down ok, and stores the data in the DB ok (Multiple meta rows for each selected item) but when you come to update your data, it only shows 1 of your options selected even though you have selected more.

    The database has more than 1 record saved as shown below:

    umeta_id – user_id – meta_key – meta_value
    333 – 8 – user_book_genres – 12543
    334 – 8 – user_book_genres – 12545

    but on your the /user/username/ page, it only shows 1 of the selected options from the DB, not 2. When editing, it only shows 1, not 2 on the profile edit page.

    There is an issue with showing multiple selected details for the drop down and does not seem to be plugin related.

    If I use a plugin with your plugin (UM Relational Fields plugin for example), I still get the same error. It shows dropdowns correctly, but showing selected options from the dropdown list does not work if more than 1 was selected and in the DB when updating.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Multiselect not saving multiple selections’ is closed to new replies.