[resolved] Multiplying Apostrophes (3 posts)

  1. battlerobo
    Posted 7 years ago #

    Just wanted to post this in response to this topic: http://wordpress.org/support/topic/84459?replies=3

    I had the same problem recently where an extra apostrophe appears all over my site (keep in mind, there is only one apostrophe in the data in the db), and if I made an edit, the extra apostrophe would be inserted into the database, thus showing up as 4 apostrophes on the site, etc.

    I had my host look into the problem, and they solved it. Basically it has something to do with the Magic Quotes in the PHP settings.

    They remedied this by inserting these two lines in the .htaccess file:

    php_flag magic_quotes_gpc Off
    php_flag magic_quotes_runtime Off

    Hope this helps anyone else having the problem (I couldn't find the solution myself!)

  2. waterhead37
    Posted 7 years ago #

    I have this exact problem with 2.5.1 but adding those lines to .htaccess just gives me internal server errors unfortunately

  3. Anonymous
    Posted 7 years ago #

    I had this problem as well.
    I have multiple virtual hosts running separate blogs on the same server.
    I tried turning off magic quotes in my .htaccess but that didn't work.
    I ended up turning it off in the php.ini file and that worked.
    I guess since it was on in php.ini it didn't care that it was turned off in .htaccess...

    hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic