Support » Localhost Installs » Multiple WordPress sites on same server won't install themes.

  • Resolved Lunatic59


    The specific problem I am having is installing themes and plugins from the dashboard.

    Server: CentOS 6.5, PHP 5.3, Apache 2.2.15 Virtual hosts enabled.

    Created a new user and installed WordPress 3.9.1 to /home/[user]/html/
    The site is live and functioning fine except for intsalling themes and plugins.

    Symptoms: I log into the site as admin/owner. Go to appearance>themes>new and browse to any theme (I’ve tried a few.) Click install, enter ftp credentials and it displays download information. It then hangs on unpacking the package …

    Plugins exhibit similar behavior.

    I have another WordPress installation on the same server in /var/www/html/wordpress/ which works perfectly for themes, updates and plugins from the dashboard.

    If I set wp-content to 777, it will continue to installing the theme but will not create the necessary stylesheet.

    Any thoughts on how I can get this working with the correct permissions? (755 for folders, 644 for file).

Viewing 3 replies - 1 through 3 (of 3 total)
  • Create a new group, call it whatever you want. Let’s say www. Add the apache user (I think it’s simply apache on CentOS) and the user to the group.

    groupadd www
    usermod -a -G www user
    usermod -a -G www apache
    cd /home/user
    chown -R user:www html/
    find html/ -type d -exec chmod 775 {} \;
    find html/ -type f -exec chmod 664 {} \;

    I think that’ll do the trick.

    All you’re doing is giving group write accecs to a small group containing just your user and the web server.

    I’m not entirely sure it’s a permissions issue.

    I had already set the ownership and the group to apache:apache. I then made the user a member of the apache group. That’s pretty much how I have the WordPress installation setup in /var/www/html and that’s working fine.

    I tried creating a new group as you suggested and made both the user and apache members of that group with folder permissions set to 775 and files at 664. I even tried setting everything to 777 temporarily to see if it would work at all. It didn’t.

    Here’s the symptoms. I will go to themes>new and select one to install. I am prompted for the ftp password and click proceed. The page begins to refresh, but both the header and the main window remain blank. If I hit refresh it may continue to downloading and then unpacking the package where it will stop.

    I’ve checked the error logs and don’t see anything failing, and the xfer log shows files copied to wp-content/upgrade/package.tmp. If I copy the contents of that folder to themes, the themes page says the installation is incomplete … missing style sheet.

    I am able to access the site with an ftp client (Filezilla) and install themes and plugins manually. I am also able to upload media through WordPress.

    Not sure where to look next.


    After the obvious and the not-so-obvious was tried with no success, the next step is to start from scratch.

    I blew out the whole installation and removed the user and the database and began again. Obviously I missed something the first time as this time it works perfectly.

    Sometimes it’s easier to rebuild than it is to repair. 😉

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Multiple WordPress sites on same server won't install themes.’ is closed to new replies.