WordPress.org

Support

Support » Plugins and Hacks » WP RSS Multi Importer » [Resolved] Multiple Video Feeds & Lightbox – Bug

[Resolved] Multiple Video Feeds & Lightbox – Bug

  • Hi,

    There is a small bug where if you have a category with multiple video feeds which also includes YouTube feed(s) the processing does not reset the $openWindow var back to “colorbox” class. The result is that all subsequent videos (below the first YouTube video) will open in a smaller lightbox overlay.

    I’m using the DEFAULT template to display the feeds and in “default.php” the YouTube check (lines 59 to 68) I’ve added an “else” statement to reset the var:

    if ($targetWindow==0 && strpos($items["mylink"],'www.youtube.com')>0) {
    
        if (preg_match('%(?:youtube(?:-nocookie)?\.com/(?:[^/]+/.+/|(?:v|e(?:mbed)?)/|.*[?&]v=)|youtu\.be/)([^"&?/ ]{11})%i', $items["mylink"], $match)) {
            $video_id = $match[1];
            $items["mylink"]='http://www.youtube.com/embed/'.$video_id.'?rel=0&wmode=transparent';
            $openWindow='class="rssmi_youtube"';
            global $YTmatch;
            $YTmatch=1;
        }
    } else {
        $openWindow='class="colorbox"';
    }

    This fixes this issue, thought I would share so the dev can fix.

    Cheers.

    o/

    http://wordpress.org/extend/plugins/wp-rss-multi-importer/

Viewing 1 replies (of 1 total)
  • Plugin Author Allen

    @amweiss98

    Hi

    Thanks so much for pointing this out…I’ll put this fix in the next update.

    Best wishes,
    Allen

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Multiple Video Feeds & Lightbox – Bug’ is closed to new replies.
Skip to toolbar