Support » Plugin: MP3-jPlayer » Multiple tracks no longer working in playlist

  • Resolved 4dmedia

    (@4dmedia)


    Hey there,

    I am having trouble getting multiple tracks to load from my site. They were working with this player, but it looks like something has gone awry and I can’t figure out what it is.

    On the following page, you will see 5 widgets on the right side. The first 2 and 5th are instances of mp3jplayer. The 5th widget properly displays and plays the 2 sample tracks from Simon’s site, but the first two don’t display/play properly. Does anybody have any ideas as to how I can get the 1st 2 widget’s playlists to display/play properly?
    Thanks!

    http://www.dramamusicproductions.com/test/

    https://wordpress.org/plugins/mp3-jplayer/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author simon.ward

    (@simonward-1)

    Did you get anywhere with this? I can see a player at the bottom of the page only.

    Hey Simon, thanks for the quick response! The closest I got was getting the top player to display a single track of ours and the bottom player to display your two demo tracks. The goal would be to get the two top players to display all of the tracks listed in them.

    Plugin Author simon.ward

    (@simonward-1)

    The player thinks that there are no tracks for the first 2 widgets.

    One thing to check is what mode you have the widget set to. Make sure you have it actually set to the right mode via the radio buttons, and have saved it!

    Let me know if you still can’t get it going.

    Thank you for your quick response again…unfortunately, I just checked and both widgets are set to the “write playlist” radio option, I saved them both and still no luck.

    Plugin Author simon.ward

    (@simonward-1)

    I’d likely need access to the site to be able to see what’s going on here, if you’re happy to then please contact me here.

    Plugin Author simon.ward

    (@simonward-1)

    I see the problem, you cannot write shortcodes into the playlist widget like that, it should just be the list of urls, comma separated.

    If you want to do it by shortcode please use the other widget provided.

    Plugin Author simon.ward

    (@simonward-1)

    Update: We got this working after I looked at the site, but it has highlighted an issue that needs looking at. Basically filenames can’t contain the [ or ] chars if they are to be written manually into the widget (or shortcode). This is a current limitation.

    Many thanks to Barry for letting me debug.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Multiple tracks no longer working in playlist’ is closed to new replies.