Support » Plugin: All-in-One WP Migration » Multiple Themes settings http and not https

  • Resolved Harm10

    (@harm10)


    Hi!
    (As stated in other reports I am still testing……)
    I use plugin Multiple Themes to set different themes for different parts of my site.
    After migrating these settings have been URL renamed to the new site URL but http in stead of https.
    I should add that the site I was restoring in started out as http but in the back-up were the settings to make it https as was the site I backed up in.
    So maybe there is a problem with the sequence of events?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Yani Iliev

    (@yaniiliev)

    Yes, it sounds like it.
    Always start with the protocol that you intend to use. This will ensure that your content is properly replaced. If you switch between http and https you will get issues like the one you are describing.

    I understand. But if you want to use your back-up to migrate from http to https or vice versa these problems will always occur.
    Wouldn’t a warning be in order here? Preferably when you start the restore.

    Plugin Author Yani Iliev

    (@yaniiliev)

    Migrating from http to https or the opposite should not be an issue.

    The problem in your case is here

    I should add that the site I was restoring in started out as http but in the back-up were the settings to make it https as was the site I backed up in.

    Start with a site that is entirely using http or https. Make sure it is configured properly then import the archive.

    I know what my problem is. I am merely asking for a warning when you are restoring a backup on a site that has a different protocol that points out the potential problems. Is this possible? Or should I request such changes/additions somewhere else?

    Added a suggestion on Feedback site.

    I redid the whole testing process and set the receiving site to the correct protocol before restore and no problems cropped up.

    Plugin Author Yani Iliev

    (@yaniiliev)

    Thank you for describing what resolved it for you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.