Support » Plugin: Collapse-O-Matic » Multiple shortcode instances not working

  • Resolved muranomidwest

    (@muranomidwest)


    Hi – every feature you’ve documented seems to work great. I’ve played with most of them and haven’t run into a problem yet…except when I combine multiple instances in the same post in some way they don’t like.

    In this example you can see that some of the sections expand and collapse exactly as expected. Some expand and don’t collapse and some don’t expand. If you reload the page you may or may not get the same results in the same sections but there will always be something odd.

    Of course, I always clear the caches when trying to debug these things.

    I am using Avada and the blog post content lives inside a series of Fusion Builder containers.

    Thanks,

    Janet

    • This topic was modified 8 months, 2 weeks ago by muranomidwest.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Update – I have found that the visual builder shows an incomplete version of the shortcodes at times. If you look at the text version, an additional <span> tag is automatically added, the contents of the shortcode are scrambled and it doesn’t work right. I thought that editing each section in text mode to clean it up would fix this.

    It fixed some and not others.

    I also noticed that Fusion Builder editor will respect the single quotes in the <span> tag of my title. I always get double quotes inside of double quotes. Most of them seem to still work anyway.

    The problems with which ones display the title correctly or not and which ones expand or not still wanders around the page.

    Update – Further investigation points to problems with both the Gutenberg and Fusion Builder editors as well as a bug in the Fusion Builder. I don’t think there is any error in your code. That said, the single/double quote requirement for using html tags with some parameters is a problem and could be improved.

    1) Both Gutenberg and Fusion Builder fail to display the full shortcodes. I thought this was because of the problem with the single quotes but it is not. In text mode, you can see the entire thing, but in visual mode only a portion of the short code is displayed.

    2) The Fusion Builder will simply not allow single quotes and always turns them into double quotes. Sometimes this breaks the [expand] shortcode and sometimes it doesn’t

    3) Certain instances of the [expand] shortcode were not working at the bottom of a fusion builder container with two columns of different lengths (the shortcode following the shorter one). I thought this might be your bug but replace [expand] with the native toggle element in Fusion Builder with the same result. It was fixed by moving the heading from the next container to the bottom of the broken one; any text element after the one with the offending shortcode/toggle element fixed it.

    Sorry for the distraction. I am marking this as resolved.

    Janet

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Multiple shortcode instances not working’ is closed to new replies.