Support » Plugin: Advanced AJAX Product Filters » Multiple select – filter is very slow

  • Resolved fkoomek

    (@fkoomek)


    Hello.
    I have a problem when selecting multiple choices. With every next ticked checkbox, the filter loads slower and slower. For example, when 8 checkboxes are checked, the load time is almost 10s, maybe more.
    I tried Woocommerce default attribute filter and the load time is still the same, no matter how many choices I choose.
    You can check here: https://test.liberlapidum.com/test/en/product-cat/minerals-precious-stones/
    The Woo default filter is on the left.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Dima Holovnia

    (@dholovnia)

    Hello,

    Do your shop has variable products? If no please turn off “Hide out of stock variable” on the plugin settings page tab Advanced.

    Regards,
    Dima

    fkoomek

    (@fkoomek)

    Hi.
    Thanks for the response.
    Well, I’ve already tried all settings I could find in the plugin (including what you mention) with no improvement:(

    • This reply was modified 3 months ago by  fkoomek.
    Plugin Author Dima Holovnia

    (@dholovnia)

    Turning off “Hide out of stock variable”, “Display variation image”, “Display variation price” and “Reload amount of products” will make plugin work the same as WooCommerce filters.

    Turning on “Show all values” and the plugin will fork even faster.

    Everything else depends on your server speed. I have locally 20,000+ products and it is filtering in less than 2 seconds with all mentioned options above turned on(except “Show all values” ofc).

    fkoomek

    (@fkoomek)

    Where can I find “Display variation image”, “Display variation price”? Is it in the premium version?
    Well, I disabled almost all options in your plugin, changed the theme. disabled as many plugins as I can and the issue still persists.

    Woocommerce default filter:
    https://test.liberlapidum.com/test/en/product-cat/minerals-precious-stones/?query_type_country=or&filter_country=afghanistan-en,australia,brazil,mexico,namibia,pakistan-en,romania,russia

    Your plugin:
    https://test.liberlapidum.com/test/en/product-cat/minerals-precious-stones/?filters=country%5Bafghanistan-en-australia-brazil-mexico-namibia-pakistan-en-russia%5D

    Plugin Author Dima Holovnia

    (@dholovnia)

    I see now. This is weird. What hosting are you using?
    Could you please contact me through https://berocket.com/contact with link back here?

    fkoomek

    (@fkoomek)

    Sure, done.
    Thanks for help.

    • This reply was modified 3 months ago by  fkoomek.

    Hi.
    Are there any news on this issue? Did you receive my email?

    Best Regards,
    fkoomek

    Plugin Author Dima Holovnia

    (@dholovnia)

    Hi,

    Yes, I got your email and provide you an answer. But you never receive me back.

    I resend email again. Please check your email.

    Regards,
    Dima

    Hi.
    Well, now I got it.
    But I searched all folders and I didn’t receive your email before.
    Anyway, thank you very much, I will follow the instructions in the email.

    ksherm2019

    (@kaitlinsherman)

    I’m having similar issues and just filled out the contact form, please send me the same instructions.

    Hi.
    The instructions were about providing FTP access, so their developer could look into that issue.
    When the fix is done, I am sure it will be included in the next update.

    Plugin Author Dima Holovnia

    (@dholovnia)

    Hi @fkoomek,

    We didn’t get a response from you. Did you send it already?

    Regards,
    Dima

    Hi. Sorry, not yet. I am in a hurry.
    Today by the end of the day I think.

    Plugin Author Dima Holovnia

    (@dholovnia)

    Hi.

    Sure, no problem. Just wanted to check that we didn’t miss it.

    Regards,
    Dima

    Plugin Author Dima Holovnia

    (@dholovnia)

    Hi,

    Thank you for the data. We are still checking the issue.

    I can tell you right now 2 things:

    1. The issue with memory goes from Minify HTML plugin you have. It is clearly visible in the error logs

    
    [05-Jun-2019 15:10:10 UTC] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 16477560 bytes) in xxxxxxxx/plugins/minify-html-markup/minify-html.php on line 53
    [05-Jun-2019 15:10:10 UTC] PHP Fatal error:  Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0
    

    I turn it off and now pages are loading with amount of attributes in the filters.

    2. Minify HTML and Query Monitor are loading your site a lot. Not sure what is going on in the Minify HTML. As for the Query Monitor – it is saving tons of data and is checking each query that is slowing down site and require RAM.

    I turned off both plugins. It is working better now. If you will get nice hosting now your site will be working fast enough. Our filters cannot load faster than normal(not cached) page.

    Regards,
    Dima

Viewing 15 replies - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.