Support » Plugin: HD Quiz » Multiple Questions with Images Not Showing

  • Resolved wildtoddman

    (@wildtoddman)


    I have 3 questions with images for answers out of the 10 questions for this quiz. Only the first question shows the images properly, the other two do not show the images at all.

    Any ideas on how to fix this?

    The questions not loading are #7 (Not Famous) and #10 (Geometry)

    Thanks for any help!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Harmonic Design

    (@harmonic_design)

    Hi wildtoddman,
    I just took a quick look and unfortunately cannot see anything wrong on the front end; it’s not that the images are not loading, it’s that the answers are not loading for those questions.

    First, make sure that you actually have answers and images for all of the answers. Perhaps you added them in but then didn’t save the question?

    Assuming that is not the issue, I’ll need more info to help diagnose.

    Please edit wp-config.php located in your main WordPress installation folder and set define('WP_DEBUG', false); to define('WP_DEBUG', true);. If that line does not already exist, then you can add it just above where the comment /* That's all, stop editing! Happy blogging. */ appears. Once done, load the quiz and see if any errors or messages appear near those questions and let me know! The debug info should go a long way to helping figure out what the problem is.

    You meant the FAMOUS and GEOMETRY questions. The images are not showing on the front end for these two questions. As HD stated – do make sure you have a text answer as well as the image answer set for each answer. I found I had problems when not using square images so make sure your answer images are all square? (is that correct HD?)

    The images were not the problem, I did not realize that you also had to have a text answer to go with each image. But now they are all good and working great!

    Thanks for your help!

    🙂 Groovy!

    Plugin Author Harmonic Design

    (@harmonic_design)

    @bzzktt thanks for your input!

    @wildtoddman glad you got this sorted out and I think you helped me find a minor bug!

    Each answer needs a text option as well so that A) Screen readers and stuff can still use HD Quiz, and B) so that the radio buttons have something to toggle with. There is supposed to be a check to make sure you entered a text option as well, but it doesn’t seem to be always firing off. I’ll have fixed for the next version.

    This is one more thing that I found while setting up my first quiz.

    You can NOT use the quote (‘) in the answer or it will stop showing everything after the quote mark. And when you go back into the question, it will have deleted everything after that quote.

    No… I also asked this. Quotes get stripped/parsed from answers so you can’t use them.

    I have the same problem, some images appear, and some do not, can any one help please?

    Plugin Author Harmonic Design

    (@harmonic_design)

    @jotnarta
    please create a new support thread with a link to the quiz and I’ll help as best as I can

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Multiple Questions with Images Not Showing’ is closed to new replies.