Support » Fixing WordPress » Multiple problems with images. 1×1 pixels, errors when uploading and others

  • Hi everyone.

    I am having problems with one of my sites. All the images on the Media page have 1×1 dimensions.

    This is not the only problem.
    When I upload a new image (either from the Add new link on the Media page, or from the Add media link when creating a new post) – I get not a very informative error that says: HTTP error and that’s it.

    I tried using the Browser uploader mode – which after pressing the Upload button actually redirects me to a 404 page of the front-end (my theme’s 404.php file). Which is really bizarre. What is also bizarre – is that the URL does not change to a 404-like. It remains like this: http://sitename.com/wp-admin/media-new.php.

    When reloading the Media page after these errors I see that the image was actually uploaded. It also is available when creating new posts, although it does not allow me to change its size (there is no dropdown for that, only Alignment and Link type are present) – it then is inserted into the post with attributes width and height set to 1.

    Also when I go to my uploads folder – I don’t see any cropped files (although I have two add_image_size functions in my functions.php file. I checked the folder permissions – they are 755. Temporary change to 777 of the Month, Year and Uploads folders does not change anything.

    So there seems to be something strange going on. Also worth noting that it’s only on one of my sites, on others – everything’s good.

    In a nutshell:

    1. images are shown as 1×1 dots on Media page
    2. Cannot upload an image (get HTTP error). Browser uploader redirects to a 404 theme page.
    3. Images don’t get cropped and scaled although two additional sizes are specified.
    4. There is no select for the size upon inserting an image into the posts (possibly because of point 3 – WP does not seem to have any sizes)
    5. The resulting inserted image has attributes width and height set to 1.

    I have searched the forums and saw that there are several issues with 1×1 dimensions, but I haven’t tried anything to solve it.

    I’m not a novice in theme development (and not an expert either) and have just tried deactivating all my plugins and switching to the twenty14. No effect. I may be having a mis-configured server, who knows, but the way I see it – it looks normal.

    Will be glad if someone could tell me something cheerful )

  • The topic ‘Multiple problems with images. 1×1 pixels, errors when uploading and others’ is closed to new replies.