Yoast SEO
[resolved] Multiple og:image tags appearing (3 posts)

  1. cyphog
    Posted 2 years ago #

    I've got an odd issue going on my site where new posts are now showing an open graph image tag for the featured image, and then og:image tags for each image that is contained in the post.

    I can't for the life figure out why/how this is happening, and I have on the usual Jetpack disable open graph filters in place. Disabling Jetpack share doesn't change anything.

    However, if I disable Yost SEO everything is fine and no OG tags, but if enabled it adds the extra tags back. Frustrating.

    Any ideas?


    <meta property="og:locale" content="en_US"/>
    <meta property="og:type" content="article"/>
    <meta property="og:title" content="Big Life Foundation - kimpluscraig.com"/>
    <meta property="og:description" content="October 23, 2013 - "Africa is Africa because of the animals there. But we can no longer take their presence for granted. At this rate, within the next twenty years, they will be gone. Imagine a world where very soon, these animals can only be seen in the sad, drab confines of a zoo.""/>
    <meta property="og:url" content="http://kimpluscraig.com/2013/10/23/big-life-foundation/"/>
    <meta property="og:site_name" content="kimpluscraig.com"/>
    <meta property="fb:app_id" content="128556690687842"/>
    <strong><meta property="og:image" content="http://kimpluscraig.com/blog/wp-content/uploads/2013/10/BigLifeFoundation-648x1024.jpg"/>
    <meta property="og:image" content="http://kimpluscraig.com/blog/wp-content/uploads/2013/10/BigLifeFoundation-189x300.jpg"/></strong>
    <meta name="twitter:card" content="summary"/>
    <meta name="twitter:site" content="@kimpluscraig"/>
    <meta name="twitter:domain" content="kimpluscraig.com"/>
    <meta name="twitter:creator" content="@kimpluscraig"/>

    [Moderator Note: Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]


  2. cyphog
    Posted 2 years ago #

    Sorry, please ignore.

  3. sdkhotman
    Posted 1 year ago #

    Hi cyphog,
    I need to your help, I want to use your post-meta icon in my website, But I didn`t do it. If possible please help me. I am using to sahifa theme 4.0.2, which is my website demo.kukiplanet.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic