Support » Plugin: Block, Suspend, Report for BuddyPress » Multiple issues

  • Resolved avonrivercs

    (@avonrivercs)


    Issue number 1: When a member is reported, I am not able to remove the upheld status. When I click the remove upheld button, it shows as green and when it is updated, the status reverts to upheld and the button shows red. There seems to be no way to delete the report.
    Issue number 2: No email is sent to administrator that the report has been made despite the send email to administrator setting being ticked. I have reinstalled the email using the Buddypress tool, Reinstall emails (delete and restore from defaults)..
    Issue number 3: When a member has been suspended and that member tries to log back in, there is no message telling them that their account has been suspended despite the setting being ticked.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Ben at Bouncingsprout Studio

    (@bouncingsprout)

    Hey @avonrivercs,

    Bearing in mind it’s Sunday, I might not be able to get solutions to you for all these right away, but I wanted to at least start the ball rolling.

    In strict order:

    1. Please ensure you are using version 3.3.0 of the plugin
    2. Next, disable ALL plugins APART FROM our plugin and BuddyPress
    3. Next, please see if the problems still exist. If they do, please create a separate issue for each, so I can keep track of each issue (this was what I was getting to in our email thread, but I may not have been clear enough)

    Speak soon,

    Ben Roberts

    Thread Starter avonrivercs

    (@avonrivercs)

    Hi Ben, I don’t expect you to work on this tonight but I have checked and the version is 3.3.0. I have deactivated all plugins except Sweetdate, Buddypress and BSR. A member reporting another member results in a report being logged and email is sent to the admin. I still can’t remove the upheld status of the report.

    Thread Starter avonrivercs

    (@avonrivercs)

    With plugins disabled, the suspended member does get the suspended message as expected. So this looks like there is a conflict somewhere. I will activate the plugins to see where the issue is and report back

    Plugin Author Ben at Bouncingsprout Studio

    (@bouncingsprout)

    Hi @avonrivercs,

    We’re in danger of getting these multiple issues lost, but I’ll do my best.

    So by the sounds of it, we now have two issues left:

    • You cannot change the upheld status – this shouldn’t impact you a great deal. The uphold system is an advanced feature and will only impact your site when you are dealing with suspension thresholds. I will look into it.
    • Another plugin is trying to override our suspension message – you are doing the right thing by slowly enabling plugins until you find the cause. Please let me know how you get on.

    Ben R

    Thread Starter avonrivercs

    (@avonrivercs)

    Hi Ben,
    Enabling plugins one by one, as soon as I enabled Paid Memberships Pro, the message disappears from the log in form and simply displays “There was a problem with your username or password.” no suspension message. I have now enabled all plugins except for Paid Memberships Pro, and I receive the suspension message. This looks to be the root of this issue.
    Steve

    Plugin Author Ben at Bouncingsprout Studio

    (@bouncingsprout)

    Hey @avonrivercs,

    I have now installed Paid Memberships Pro, and on my system the suspension message correctly displays – https://prnt.sc/126tmz7.

    If you still believe PMP to be the cause of the issue, it may be to do with how you have set that plugin up (I am not familiar with it). You may decide that the developers of that plugin my be able to assist you further.

    You could try to install PMP again, ensuring that you have removed all previous data (so it is a clean install as it would be on my system).

    Best of luck,

    Ben

    Plugin Author Ben at Bouncingsprout Studio

    (@bouncingsprout)

    Hi there!

    As I haven’t heard back from you in over two months, I am marking this as resolved.

    Ben Roberts

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Multiple issues’ is closed to new replies.