Multiple Fatal Errors After Install (5 posts)

  1. jbkc85
    Posted 5 years ago #

    All of the mentioned errors is after a clean install with no additional modules.

    1. Upon Visiting Admin Dashboard: PHP Fatal error: Call to undefined function wp_dashboard_setup(). This is of course fixed with the hack:

    /** Load WordPress dashboard API */
    #require_once(ABSPATH . 'wp-admin/includes/dashboard.php');

    However, I don't want to use a Hack to fix something in WordPress.

    2. Upon Uploading a Module, or trying to install I get the following:
    PHP Fatal error: Class 'Plugin_Upgrader' not found.

    PHP Modules:
    [PHP Modules]

    [Zend Modules]

    PHP Version:
    PHP 5.2.17 with Suhosin-Patch 0.9.7 (cli)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies

    Any pointers that anyone has to avoid these issues? It all seems to be stemming from the "ABSPATH" variable, however it is set correctly (and I echo'd) in the wp-config.php.


  2. jbkc85
    Posted 5 years ago #


    I have attempted to install multiple WordPress, and this really seems to be a problem with the ABSPATH while in the wp-admin. For some reason the ABSPATH -DOES- show to be the correct absolute path, but the index.php and others don't seem to appreciate the ABSPATH. Does anyone know if there is being work on this, or if I need to do something with my php.ini to fix this issue? It is really hampering all development..

  3. jbkc85
    Posted 5 years ago #

    I experienced this same issue in 3.0.4, 3.0.3, and 3.0.2. Is this still the same bug?

  4. craftsyr
    Posted 5 years ago #

    Did you ever have any luck with this? I have the same issues.

  5. craftsyr
    Posted 5 years ago #

    I found that upgrading from php 5.2 to 5.3 solved this for me.

Topic Closed

This topic has been closed to new replies.

About this Topic