Support » Plugin: Content No Cache: prevent specific content from being cached » Multiple “Content No Cache”

  • Hello Jose,

    Like your plugin very much!

    I have a question. On my homepage I have one section in the middle and at the bottom which I want to uncache, that is random content.

    Made for one of each section a CNC shortcode, but when I use two shortcodes at the same page, one section won’t show up. When I use one of the two shortcodes there is no “conflict”.

    Hope you can help me out.

    FYI, I’m using Elementor for the page build.

    Thank you!

    • This topic was modified 10 months, 3 weeks ago by ikke77.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jose

    (@giuse)

    Hi @ikke77 many thanks to you!

    Theoretically, it should work also with two or more shortcodes.

    Is the section at the bottom still in the page content? Or is it in the footer?

    Do you see any red errors in the console? To see the console:
    – Inspect elements (right-click => Inspect Elements)
    – Click on Console

    Would it be possible for you to link the page?

    Thread Starter ikke77

    (@ikke77)

    Hello Jose,

    You are welcome!

    I have one section around the middle of the page an the other just before the footer.

    Now I have only one “no cache” section active and in firefox I got the notice: “Uncaught TypeError: els[i] is undefined”

    Plugin Author Jose

    (@giuse)

    thank you @ikke77

    that errors should occur if you don’t specify the id in the shortcode.
    Maybe it’s a matter of wrong double-quotes due to a copy/paste issue.
    Could it be that you did a copy/paste of the shortcode and then replaced the id? If so, you may have the wrong double quotes, and the id parameter is not taken.

    You have a shortcode that looks like [content_no_cache id=”3328″], I suggest you delete the double quotes and write them again manually. Let me know if it works.

    Clear the cache before checking.

    Thread Starter ikke77

    (@ikke77)

    Hello Jose,

    Thank you for you info!

    I checked and followed the way as you advised, but that didn’t resolve the problem when I have 2 sections. I also deactivated all plugins, but that unfortunately didn’t help.

    With 1 section, everything ok, “except” the notification in the console of Firefox a notification in de console.

    When I put 2 NC sections active, I got below notification in Firefox:

    Uncaught TypeError: els[i] is undefined
        onload https://staging.example.com/:1020
        eos_dyn_get_content https://staging.example.com/:1020
        <anonymous> https://staging.example.com/:1020
    staging.example.com:1020:241
        onload https://staging.example.com/:1020
        (Async: EventHandlerNonNull)
        eos_dyn_get_content https://staging.example.com/:1020
        <anonymous> https://staging.example.com/:1020

    Just FYI: when I make a CNC in your plugin, standard the <p> <p> tags are added, this is normal~ok?

    Again thank you!

    Plugin Author Jose

    (@giuse)

    Hi @ikke77

    please, update to 0.0.5 and let me know if you still have the same issue.

    Thread Starter ikke77

    (@ikke77)

    Awesome Jose!

    Works perfect, thank you, I’am very with this!

    One-more-thing, just an FYI: (I’m working with Elementor)
    On certain pages I use the post-widget to show 3 random related posts and exclude the current post. That works ok, but when I make a CNC block, it ignores the exclude current post setting.

    Again thank you!

    • This reply was modified 10 months, 1 week ago by ikke77.
    Plugin Author Jose

    (@giuse)

    You are welcome @ikke77 !

    I’m happy that it works.

    For this other issue, you can try the new version 0.0.6. You can find it here: https://downloads.wordpress.org/plugin/content-no-cache.0.0.6.zip
    It’s not public yet.

    After the update, you need to add the shortcode parameter request=”remote”.
    You have a shortcode that looks like [content_no_cache id=”3328″], you should replace it with something that looks like [content_no_cache id=”3328″ request=”remote”].

    Adding request=”remote”, the content will be served a little slower, but it may solve this other issue.
    When you have no problems don’t use that parameter, only if you have issues.

    Please, tell me if it solves the issue in your case, if so, v.0.0.6 will become the new official version.

    Thread Starter ikke77

    (@ikke77)

    Hello Jose,

    I tried several configurations~options, but unfortunately your new version 0.0.6 didn’t resolve the issue.

    Thank you! and hope you find a solution.

    Plugin Author Jose

    (@giuse)

    Hi @ikke77
    you are welcome!
    Just for clarification. Version 0.0.5 solved the first issue with two shortcodes.
    Version 0.0.6 didn’t solve the issue with the post widget, this is clear. But does 0.0.6 still solve the issue with two shortcodes? I suppose yes, but just to be sure.
    I will try to replicate the same issue with Elementor and will let you know when I have news.

    Thread Starter ikke77

    (@ikke77)

    Hello Jose,

    Exactly as you say:

    – V.0.0.5 did resolve the issue with two shortcodes;
    – V.0.0.6 did resolve the issue also with two shortcodes, but not with the post widget.

    Thanks and have a nice weekend!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Multiple “Content No Cache”’ is closed to new replies.