Support » Plugin: Widget Logic » Multiple Conditions aren’t working

  • I’m trying to create logic that will not display the widget on multiple pages. This is what I have in the Widget Logic
    !is_page('registration') || !is_page('member-login')

    If I enter these conditions one at a time, it does not display the widget on that page but, using the || condition, it fails and shows the widget on both pages.

    Is the plugin not designed to support multiple conditions like this?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter Marj Wyatt

    (@marjwyatt)

    Bump —

    Thread Starter Marj Wyatt

    (@marjwyatt)

    Since support hadn’t come back with an answer after two weeks of waiting, I searched for “widget logic functions” on the web and found a useful like. I’m providing a link from another site that provided the solution:
    https://khromov.wordpress.com/2012/07/17/common-uses-for-widget-logic/

    In essence, I had to use the page IDs in an array thus:
    !is_page(array(1,5))

    Personally, I think using page/post IDs is a bit clumsy.

    I still don’t know why the or condition using page slugs didn’t work so I’m keeping this question open because, based on the description/use instructions, it should have worked the way I had previously coded it.

    !is_page(array(‘one-page’,’another-page’)) works for me.

    hth,
    Alex

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Multiple Conditions aren’t working’ is closed to new replies.