WordPress.org

Support

Support » How-To and Troubleshooting » Multiple bogs – cannot update template

Multiple bogs – cannot update template

  • Hi there.
    I’ve installed two copies of WP into two different directories. Each install has got its own database to write to.
    Everything was works fine except that I can’t update or change the template (index.php) I am getting an error message that I have to make index.php writeable (666) which it is.
    Any suggestions would be most appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Mark (podz)
    Support Maven

    @podz

    You are trying to update the wrong index from the one you think you are .

    Still no luck. I did yet another clean install, same result.
    There appear to be two issues:
    1. I can’t update the index.php template. Error code: Needs to be writable e.g. 666. The ‘comments’ template updates with no problem which is really weird.
    Also, when installing WP didn’t guess the install folder, it got stuck on domain.com
    I already run another install of WP on the same server (different database, different sub directory) with no issues at all.
    I made sure to go through my permissions, but with no luck.
    Any pointers?

    ColourDreamer
    Member

    @colourdreamer

    My host automatically installs WP for us, and in my new install, I get this problem with my template.

    Are ‘Web Address’ and ‘Blog Address’ (Options -> General) set up correctly in both of your blogs?

    ColourDreamer
    Member

    @colourdreamer

    Mine’s correct.

    I’m having the same problem updating my template. Permissions are right and I don’t even get any error, it says file updated successfully, but it is not.
    I have to manually upload the index.php via FTP. any help?
    Wordpress address: domain.com/wp
    Blog address: domain.com

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Multiple bogs – cannot update template’ is closed to new replies.