[resolved] Multiple Attempts 2.0.4 Upgrade Failure - Page Cannot Be Displayed (52 posts)

  1. ronams
    Posted 9 years ago #

    I upgraded from 2.0.3 to 2.0.4. My Blog disappeared (www.strategy2execution.com/blog), but can be found on http://www.strategy2execution.com/blog/wp-admin. The database seems to be working and complete.
    A second problem was that got a blank page on Manage posts. Manage pages was ok. Since re-installing multiple times, now I only get "Page Cannot Be Displayed". I can no longer even get Manage pages. When you click on Manage, the url is http://www.strategy2execution.com/blog/wp-admin/edit.php

    Some Issues:

    • I've checked the upgrade files (as downloaded and unzipped) and they mostly seem to have a carriage return after the ?> at the end files (e.g. edit.php and wp-config.php) This seems to be true in almost all the files I looked at. I've removed the carriage returns on those files, but can't believe that's the problem since it seems to exist on all the files I've looked at.
    • I've downloaded the upgrade and uploaded with my edited wp-config.php.
    • It's not certain whether the .htaccess was backedup originally or not. I've recreated this file and have the right access (666)

    Please help. I've scoured the support pages and have been down for a couple of weeks trying to sort this out myself.

  2. ronams
    Posted 9 years ago #

    • Also add that the plug-ins are all deactivated.
    • the other areas of wp-admin seem to all work except the Manage area. It immediately goes to "Page cannot be Displayed
    • There are no error messages, since it just reverts to the internet explorer "Page cannot be displayed"
  3. Doodlebee
    Posted 9 years ago #

    Just a quick question...the URL you gae for your blog isn't the URL you go to. If you put that URL in the browser, it redirects to another site. Is that *your* redirect and your site (and you put in the wrong URL for some reason), or did you even know it was doing that?

  4. ronams
    Posted 9 years ago #

    This is a redirect. It was working fine before the upgrade. You can also go to http://www.h2roadmap.com/blog and the same failures occur.
    I didn't mean to repost, but thought that it was better matched to the other support section since it was running (at one point).

  5. Doodlebee
    Posted 9 years ago #

    Well, I notice it's a *completely* blank page - meaning, when you view the source code, there's nothing there, either. Usually (at least in my experience) that means there's a PHP error somewhere. (It could be a database error too, but we'll go with what I quasi-know, in hopes it helps you until someone smarter comes along!)

    Do you know if your PHP error reporting is turned on? If it *is* a PHP error, then it's not - because it would show you the error and exactly where it is. If it *is* on, then it's something else that's wrong.

    We can easily find out if error reporting is on if you can create a PHP file and uplaod it. Just open up Notepad and put in "<?php phpinfo(); ?>, save it as "test.php" and upload it somewhere on your server. Doesn't matter where. Just post back the URL and we'll see what's there :)

  6. ronams
    Posted 9 years ago #

    I hope this is what you meant. I created test.php with just <?php phpinfo(); ?> in it. I didn't put the leading " in it. It is in the folder http://www.h2roadmap.com/blog
    url is:


  7. Doodlebee
    Posted 9 years ago #

    Yep - that's what I wanted.

    Well, you *do* have error reporting turned on, and you already have it set to display errors. So it looks like your problem isn't a PHP one (as far as getting far enough to display the errors that's causing the issues, anyway).

    Okay, I did a search on this problem, and on eof the big suggestions is this:

    log into your admin area. Turn off all your plugins, reset your theme to "default" and see if that brings up your site.

    It's a start :)

  8. ronams
    Posted 9 years ago #

    Thanks for following up. I've been down since Aug 8 trying fix it myself. This is a business based blog and so it's starting to hurt a lot.

    There are no plug-ins active and I have reset the theme to the default. I've done this many times trying to fix it before with no luck. Thanks again for sticking with me on this.

  9. Doodlebee
    Posted 9 years ago #

    No problem - although I don't know how much help I'll actually be!

    Let's see....

    Have you tried re-installing 2.03 and then re-upgrading? (Or even just reverting back to 2.03?) Could it be possible that a file was corrupted somehow during the upload of 2.04?

    Also, have you tried logging into your database (with phpMyAdmin) and looking to see if there is data in your tables?

  10. Doodlebee
    Posted 9 years ago #

    Here's something you might try - open up wp-config.php in your text editor, and put in this line:

    define('DISABLE_CACHE', true);

    Save and upload - see if that helps?

  11. ronams
    Posted 9 years ago #

    I've tried multiple re-installations of 2.0.4 and have tried to re-install 2.0.3 with same results.

    I also just tried define('DISABLE_CACHE',true); with no change.

    One thing that I'm curious about. All the documentation says there should be no extra characters spaces carriage returns etc. after ?> in a php file. Yet, I look at most of the .php files that are part of the upgrade e.g. wp-config.php edit.php and they all have a carriage return after the ?> Any thoughts. Any suggestions. I'm having people turn off their links to my site since I've been down so long.

  12. Doodlebee
    Posted 9 years ago #

    yes, but when you reinstalled and/or disabled the cache - did you clear the cache in your browser as well (close the browser window, re-open, go to home page, clear cache, then go to your site), or just reload the page?

    As for the extra whitespace - if that were the problem, you'd get an error message saying something like "headers already sent". We've already determined that your error reporting and display is already turned on - yet no errors are shown. So whitespace isn't the problem.

    Another question is this: before you tried the upgrade, did you backup your database and files? If so, why not delete your wordpress files and database tables, and start with a fresh install of 2.04?

  13. ronams
    Posted 9 years ago #

    Yes, I did clear cache in multiple ways, including windowasher.
    In terms of upgrade, I've deleted and re-installed everything except clearing the database tables.

    Before I delete the tables in the database, I can see all the postings in the blog/wp-admin area. I can even bring up on i.explorer individual posts and can see them on the wp-admin recent posts that shows up on the right side of WP-Admin. It seems like that there there. The manage screen doesn't come up at all. (e.g. wp-admin/edit.php this also show The Page Cannot Be Displayed Once upon a time, before the other attempts at fixing the missing entry page, hitting manage brought up a blank page (rather than the current page cannot be found). When clicking on manage pages (as compared to posts), it showed all the pages correctly. Now neither show up and I get the page cannot be displayed.

    I guess I just paranoid about whether the database back up is good. There doesn't seem to be a good way to test that. Yesterday I did some exploring in what is online and it all seems to be there (all the posts etc.). I haven't found a way to test whether the one database back up is good.

  14. Doodlebee
    Posted 9 years ago #

    Don't delete your database yet. It seems that it's working fine, if you can see your posts and such.

    I just tried to view your wp-content folder, and it also comes up as a blank white page. However, there's a difference: when you view source, the HTML is there - there's just nothing in it. (In IE, your blog page comes up as a 404 - Page not found.)

    Hmm...here's a question - what are your file permissions set at? Folders should be 755, files 644...

  15. ronams
    Posted 9 years ago #

    Checked all of them. All folders 755 and file 644 except .htaccess that is 666.

  16. Chris_K
    Posted 9 years ago #

    Say.. what's in that .htaccess? Have you experimented with temporarily renaming it?

  17. ronams
    Posted 9 years ago #

    Here's what's in it.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]

    # END WordPress

    I've re-created it many times, but not sure what renaming it would do, so haven't tried anything like that.
    Thks for the help.

  18. Chris_K
    Posted 9 years ago #

    Rename it to .htaccess.bak just for grins. WP won't see it and may act a bit differently.

    Sure, I'm grasping, but it'll only take a minute to try. :-)

  19. ronams
    Posted 9 years ago #

    No change when renaming .htaccess to .htaccess.bak.

    But did find something interesting. At the bottom right of the wp-admin there is blog stats. I can't look at the posts (cannot display page), but I can look at the comments. On that page that shows all the comments, you can choose to edit comments. When I bring that up edit-comments.php I get a good Manage Page (created by edit-comments.php) I can again select edit-pages.php and get a good page, but if I select edit posts (edit.php) again I get the page cannot be displayed.

    Hope this helps. Does this not mean in both the index and the edit.php they are both trying to display all the posts at once and fail.

  20. ronams
    Posted 9 years ago #

    FYI, having seen that edit.php is always failing, I've uploaded it from fresh upgrade versions a couple of times in case it was corrupted. No luck on that fixing it.

  21. hawkinsr
    Posted 9 years ago #

    Apologies for jumping in on your problem but I have been following this thread and am also experiencing upgrade problems from 1.5 to latest and I didn't want to duplicate another thread. I'm stuck.

    I have read and reread the instructions and tried twice to delete old and upload new files. I have checked DB is intact but for some reason I cannot access the upgreade.php page or any other.

    My Blog has gone BLANK through the browser and yet all the files are there with the correct dir and file permissions

    I would appreciate and help or guidance anyone can give. I have trawled the site but to no avail. Many thanks rus (the blog resides in root at http://www.04gh.com)

  22. Doodlebee
    Posted 9 years ago #

    Kay - well, I'm at a loss.

    If it were me, I'd just FTP into my area, delete all wordpress files and just fresh-install 2.04.

    Of course, knowing me, that's probably not the right way to do it. This flabbergasts me.

    Sorry I couldn't help more!

  23. Chris_K
    Posted 9 years ago #

    Doodlebee, that'd be spot-on the thing to do I think.
    Get a fresh zip and start over.

    Save wp-config.php and anything under themes that you're in love with first, I reckon.

    I too am at a loss.

  24. ronams
    Posted 9 years ago #

    I have done this countless times. Cleared all out of my site and reuploaded a fresh upgrade set of files. I then upload a new wp-config.php and .htaccess. No change.

    I don't know what else to do.

  25. Doodlebee
    Posted 9 years ago #

    Ronams - I know this is crazy, but how would you feel if someone else gave it a try?

    If you email me (you can go through my form at http://www.anekostudios.com/contact.php) let me know if you'd be interested in having me give it a go.

    And hawkins...

    1.5 to 2.04? Have you upgraded to versions in between? I can't remember which ones first - but you can't just go straight from 1.5 to s.04 - you have to upgrade slowly with other versions first. You didn't say if you had gone that route or not, so I'm just putting it out there, just in case!

  26. Chris_K
    Posted 9 years ago #

    Anything interesting showing up in apache error logs?

  27. intoxination
    Posted 9 years ago #

    For some reason either WordPress or Apache is sending a redirect header (I would guess it is in Apache). It could be coming from your parent directory, but here is a raw dump of the packets going to your blog site:

    GET /blog HTTP/1.1
    Accept: */*
    Accept-Language: en-us
    Accept-Encoding: gzip, deflate
    User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; Maxthon; .NET CLR 2.0.50727; .NET CLR 1.1.4322; InfoPath.1)
    Host: http://www.strategy2execution.com
    Connection: Keep-Alive

    HTTP/1.1 301 Moved Permanently
    Date: Wed, 30 Aug 2006 18:40:58 GMT
    Server: Apache/1.3.33 (Unix) ApacheJServ/1.1.2 PHP/4.3.10 FrontPage/ Rewrit/1.1a
    Location: http://h2roadmap.com/blog/
    Keep-Alive: timeout=15, max=96
    Connection: Keep-Alive
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=iso-8859-1

    <TITLE>301 Moved Permanently</TITLE>
    <H1>Moved Permanently</H1>
    The document has moved <A HREF="http://h2roadmap.com/blog/">here</A>.<P>


  28. ronams
    Posted 9 years ago #

    I don't think the re-direct is the problem, but I'm desparate and hope that it could be.

    I have more than one url pointing at the same site.
    During my 2.0.3 blog days, either http://www.strategy2execution.com/blog or http://www.h2roadmap.com/blog would go to the blog correctly and all would work. http://www.h2roadmap.com is the base url, but the name http://www.strategy2execution.com is the actual focus of the blog's material.

    I continue to try both when I try to get to the blog and both fail. Today I changed the entry in the wp-admin options to http://www.h2roadmap.com/blog to ensure no potential confusion. But it hasn't had any impact.

  29. intoxination
    Posted 9 years ago #

    Just out of curiosity, have you tried to disable your gzip compression in WordPress? There is a possibility something screwy is happening in there (I have seen it happen on other platforms before).

    Something else to try is go into wp-blog-header.php and start working down and add the following in the file:

    die("test point");

    See if when you go to the site you get the test point. If you do then move it down further in the code and see where you stop getting it at. It could be something causing the crash when wp() is initialized, but this will give a better idea of where the problem is occuring.

  30. ronams
    Posted 9 years ago #

    Tried you die("Test Point") in wp-blog-header.php . I'll mark with **** where it showed up and #### where it just went to page cannot be displayed. In some cases it was in the middle of an if statement and gave a different error as some unexpected stuff. Does this help?

    if (! isset($wp_did_header)):
    if ( !file_exists( dirname(__FILE__) . '/wp-config.php') ) {
    if ( strstr( $_SERVER['PHP_SELF'], 'wp-admin') ) $path = '';
    else $path = 'wp-admin/';
    die("There doesn't seem to be a wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file.");

Topic Closed

This topic has been closed to new replies.

About this Topic