WordPress.org

Support

Support » How-To and Troubleshooting » Multipage post gives 404 with permalink set as post name

Multipage post gives 404 with permalink set as post name

  • I am trying my first multi page posts using:

    <!--nextpage-->

    My blog is set to use post name as the permalink setting. When the pagination appears it adds a /2/ for the second page which results in a 404 error.

    If I use the default (and untidy) permalink settings it works by adding &Page=2 and the second page appears.

    Does anyone know how to get it to work using post name as the permalink? I have searched the forums but not found a solution.

    Many thanks
    Mark

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator t-p

    @t-p

    Volunteer Moderator

    the default (and untidy) permalink settings it works

    If the default setting works, then try reading Using_Permalinks before setting a custom permalink structure again.

    Thank you for your reply.

    I tried the tips on the pages mentioned and subsequent linked pages but to no avail.

    I then created a new test page and it worked!

    Tracing it back the only difference between the test page that worked and the one that still didn’t was the length of the pages own permalink.

    The original page was just ‘a’ as it was category A in an alphabetical list.

    For some reason a single character permalink doesn’t work but if I change it to ‘aa’ it does! I can change all the page permalinks but would be interested to know why this should be the case and if there is a better way to get it to work perhaps via .htacces?

    Thanks
    Mark

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Multipage post gives 404 with permalink set as post name’ is closed to new replies.
Skip to toolbar