Support » Networking WordPress » Multilingual Press on Multisite WP: subpath site not showing

  • Resolved sundancemak

    (@sundancemak)


    Hi everyone.
    I’m trying to have a site where I can switch from a language to another clicking on link (i.e. a flag) in the homepage.

    I’ve installed Multilingual Press plugin after setting up WP Multisite as indicated.

    I chose subpath option for the second site (www.mysite.com/eng).

    My problem: When I go on that website nothing appears but this message:
    Parse error: syntax error, unexpected T_STRING in /home/username/domains/www.mysite.com/public_html/wp-content/themes/minimatica/404.php on line 18

    The theme I’m using is Minimatica.

    Any help please?
    Thanks.

    Marco

Viewing 14 replies - 1 through 14 (of 14 total)
  • Can you test with a different theme?

    Good morning from germany.
    I have a similar problem. After installing some Plugin-Updates last night, the site turned down with a text message, something about “Maintenance… Service not available”. I thought it was something from my ISP. This morning a theme update was left. And after installing it, the site (only admin) turned down again. My ISP sends me this error-message: [30-May-2012 09:12:57] PHP Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in xxx/wp-content/plugins/multilingual-press/inc/class-Mlp_Settingspage.php on line 373
    Not sure, if there was an update for multilingual-press last night.

    I’m using the Yoko-Theme and WP 3.3.1 here

    I’m going to test with a different theme and then let you know. However I’d like to not change it and find any solution to have a site where I can put a flag in the homepage so to switch the language.

    Thanks for your help.

    Marco

    I tested with several themes, also with specific multi-language ones, but the result is the same: it can’t find the page when I click on the flag to visit the secondary site.

    I may have misdone some setting..?
    Anyone can help please?

    Regards,

    Marco

    p.s. Don’t know if I can put my personal site address here, but if it can help to find the problem it is http://www.marcocarucci.com

    Are you sure, your URL is correct? http://marcocarucci.com/eng?noredirect=en

    job

    re: to my own problem

    It seems, as there is a PHP 5.2 incompatibility within the 0.8.1-plugin

    job

    /eng is the subpath I set up for the english version (the secondary site) that doesn’t open.

    I’ve checked Home, Siteurl and FileuploadUrl and about the incompatibility it sounds weird as I’m doing everything in a WP environment…how do I check that?

    regards,

    Marco

    pressjob – Please don’t hijack other people’s threads next time 🙂 You should make your own topic.

    sundancemak – Specifically change http://marcocarucci.com/eng/ to use TwentyEleven. Does that still fail? Have you tried turning off all of your plugins on the eng site?

    You can get to http://marcocarucci.com/eng/wp-admin so it’s something on the front end of the site.

    Dear Ipstenu,
    thanks for your help.

    I’ve tried also with Twenty Eleven but I’m having the same problem: when I click the link to the English version I got the error message.

    Do you know any other way to obtain two version of the same website linked each other by the home page ? I don’t know why Multisite and Multilangual Press plugin are not working but there may be another way.

    Regards,

    Marco

    Well … I’m not entirely sure what you did 🙂

    http://wordpress.org/extend/plugins/multilingual-press/ says the plugin is still in development, so really we need them to come over and help!

    They’d like you to comment here: https://github.com/inpsyde/multilingual-press

    I’ll do. Thank you again.

    Marco

    Dear Ipstenu,

    I followed your link but I haven’t clear how or where to leave my comment..

    Also, are there other plugin to set a multilingual site? Or another way as for example to make a second installation of wordpress in a subdirectory (i.e. http://marcocarucci.com/eng) and put a link on the homepages of each sites? do you have any suggestion?

    Marco

    You’d have to make a github accuont and then go here: https://github.com/inpsyde/multilingual-press/issues

    However …. Read this: http://2011.sf.wordcamp.org/files/2011/09/Taking-WordPress-to-the-World.pdf

    There are many different ways to do this.

    I finally fixed the problem even if I’m not sure about what was wrong.
    I guess the path for the subsidiary site (i.e. /en) maybe fixed and I had changed it (/eng) or more probably you need to be careful of some setting and specially “siteurl”, “home” and “fileupload url”. It’s better not to touch them at all as the first two change automatically and the last one, that I had changed, is probably fixed.

    Thanks for the help!

    Marco

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Multilingual Press on Multisite WP: subpath site not showing’ is closed to new replies.