Support » Plugin: WooCommerce » Multi-word product attributes not clickable

  • Resolved eswilliams

    (@eswilliams)


    Hello,

    I work at a retail company that is looking to launch an e-commerce site. I’m having problems with some of my product attributes not being clickable — it seems that any time an attribute contains more than one word than the problem happens. It does not seem to happen for attributes that are only one word.

    This is a link to a product page that highlights the problem:
    https://backyardlivingdirect.com/product/26-round-conversation-table/

    This is the same problem I’m having on basically every product page. There is a handful that appear to be working correctly.

    The site is built off of the porto theme. I did not build the site and I come from more of digital marketing background and backend website stuff is not strong suit. Any information as to what could possibly be causing this problem would be great.

    Thank you,

    Eric

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Your theme script file theme.min.js has this line:

    e(this).val() && (i += "<li", e(this).val() == t.val() && (i += ' class="active"'), i += '><a href="#" data-value="' + escape(e(this).val()) + '" class="' + a + '"', o && (i += ' style="background-color: #' + escape(e(this).data("color").replace("#", "")) + '"'), i += ">", o || (i += escape(e(this).text())), i += "</a></li>")

    escape(e(this).val()) is the culprit, it converts space character between words into %20. Make backup of the original file, then edit it and replace escape(e(this).val()) with e(this).val() – the escape( before and the closing ) need to be removed. You’ll have to clear your browser cache to see the updated version working.

    Superkot,

    Thanks for the prompt response. I don’t have access to the C-Panel yet but should be able to get in by tomorrow and implement the changes. Thank you.

    -Eric

    Plugin Support laceyrod

    (@laceyrod)

    Automattic Happiness Engineer

    Hi there,

    I was able to check out your product page and see that the following issue is now resolved. I’m going to mark this thread as “resolved” now, but please be sure to create a new post/thread if you have any other questions or concerns.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Multi-word product attributes not clickable’ is closed to new replies.