WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Multi Steps not working

[Resolved] Multi Steps not working

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author webheadllc

    @webheadllc

    Hi botervet,

    I visited your site and looked at the html source code. I don’t see the hidden “step” input.

    If you visit the example, http://webheadcoder.com/contact-form-7-multi-step-form/ you can see that there is a <input type="hidden" name="step" value="1-3" class="wpcf7-hidden" /> element in the form. This is needed to tell the plugin that the form is a multi-step form.

    Everything works fine for me except the attachments. I’m not receiving them via email. I’m using the corresponding tag such as [your-form] in the “File attachments:” section. But the files still will not appear in the confirmation emails. Any suggestions?

    I went to the example form an i do see the code <input type=”hidden” name=”step” value=”1-3″ class=”wpcf7-hidden” />. It is in mine on the first step, when u hit next u stay at the first form and the mentioned code is gone. This is a great plug in addition for Contact Form 7… but. My site is http://www.bluebirdhealth.com. Any help is much appreciated.

    Plugin Author webheadllc

    @webheadllc

    Sorry, File attachments will only work on the last step of the form.

    @HBnC Design – I don’t see the hidden tag on your site. Did you take it out?

    Hello,

    Can you please check my site. http://therealtypoint.com/sellmyhome6/ . I’m using this plugin and I follow all the steps installing this plugin but it didn’t work. It seems like on the next page only this text is displayed “Please fill out the form on the previous page”.

    relandpigte1988
    I have wasted alot of time trying to get this one feature for my client fixed. After several hours of research I finally made some forward progress. I do have the forms advancing to the next but it is only collecting the info from the last form.

    Try this:
    on_sent_ok: “location = ‘http://yourdomain.com/thank-you/’’;”

    not this:
    on_sent_ok: “location.replace(’http://yourdomain.com/thank-you/’);”

    I found this on http://contactform7.com

    I will be checking a few more setting to see if I can verify any other issues. I know how frustrating this is…I really do. All the websites say to use the () but this gave me some hope.

    Good Luck
    Charles Duggan, owner
    HBnC Design

    Just a quick bump to see if anyone has found a solution to get this plugin working correctly yet?

    In my web site , I have used 1 normal contact form 7 and multi page form. Normal form is working well and sending email to my mail id , but in the case of multi page forms , it is not sending any messages to my mail id .

    Please take a look in it here

    Plugin Author webheadllc

    @webheadllc

    Not sure why this wasn’t happening on my website before this past week, but since it is now I was able to resolve it. I was checking for magic quotes, but apparently wordpress also adds slashes. Please try version 1.3.6. “Please fill out the form on the previous page” error should be fixed.

    I have the form working on my site as of now. But I have it sending a email and the client has to download the information from Contact Form DB. But it is finally working….

    My form is working but not receiving any email:

    Get Quote

    Three step form. Code used after each submit button is:

    [hidden step “1-5”]

    [hidden step “1-9”]

    [hidden step “1-12”]

    (I tried some other like 12-12 etc) but nothing.

    Could anyone tell what is the correct code to be used so that I receive the email after submitting the form.

    Same problem here.. sure hope the author stops by soon.. client is getting antsy…

    http://wordpress.org/support/topic/not-redirecting-period?replies=4

    Plugin Author webheadllc

    @webheadllc

    if you have 3 steps in the form, the last number should be 3. The first number corresponds to the step you are currently on.

    On your first form you should have [hidden step "1-3"]. On your second form you should have [hidden step "2-3"]. And on the 3rd and last form you should have [hidden step "3-3"].

    Thank you…wonderful…its working now 🙂

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Multi Steps not working’ is closed to new replies.