Support » Plugin: BackWPup - WordPress Backup Plugin » Multi-Site + WPCron -> Multiple Backups

  • Resolved snoffel

    (@snoffel)


    Thanks a lot for your great plugin!
    As others reported already, there is an issue with multi site installations together with WPCron. I managed to work around it with an external Cronjob Service, but i would love to see this bug fixed and everything again under the control of our system.

    I made some tests and want to share my findings with you – maybee it helps fixing the problem:

    – I have an multisite installation with 19 Sites (1 MasterSite 18 Subsites)
    – lots of sites started as a Clone of another Site
    – My Job is a Database Backup, ALL Tables, daily at 2:20, Tar GZip, Upload to Dropbox
    – When i start manually or via external link: everything is fine: 1 Backup, all Tables, Duration approx. 30 Seconds

    Last night i switched back to WPCron, this is what i got:
    – in the logs and in the Dropbox i find 8 Backup Files, written between 02:22 and 05:34
    – inside these backups i find only the Tables belonging to ONE Site, so the data to 11 other sites and the master-installation Tables are not included!
    – i can’t find a rule why it is these 8 sites out of the 19. There are new ones and old ones included, high and low Site-IDs, Sites with Subfolder-Adress and Sites with mapped Domains, high traffic and nearly no traffic sites.
    – i installed the PlugIn WP Crontrol to have a look inside the Cron Tables: i only find in one old site (but not THE oldest) backwpup_cron: {“id:” 3} (this is my BackWPUp Job-ID)

    Any suggestions how to get WpCron running correct again?

    Do you need any more logfiles or even special tests i should run for you? I would be happy to share more details in PM.

    Thanks,
    Claus

    • This topic was modified 1 year, 3 months ago by  snoffel.
Viewing 31 replies (of 31 total)
  • You are right. I posted the fix, because I could not find the real problem.
    Line 60 could be the reason for the multiple cron-backups.

    I think it should be an OR instead of AND in line 60.

Viewing 31 replies (of 31 total)
  • The topic ‘Multi-Site + WPCron -> Multiple Backups’ is closed to new replies.