WordPress.org

Forums

Multi-Site Weirdness - Some Subdomain Work, Some Don't (4 posts)

  1. 3dperuna
    Member
    Posted 2 years ago #

    I'm having some Multi-Site Weirdness. Some subdomains work just fine. Click on a menu item (to a page) and it takes you to the page. Some don't work. Click on a page and it takes you to the page set as the "static" page, or whatever is default.

    I took over management of the site from a different developer, so I'm still trying to figure out what they did (and some seems rather hacked inelegantly).

    Working site
    .
    Non-Working site. Click on "Contact Us" on both sites to see the issue.

    Note: If I modify a working site in any way it becomes a non-working site. This includes updating permalinks, modifying a page, etc.

  2. 3dperuna
    Member
    Posted 2 years ago #

    The base site gives a "page not found". Here

  3. 3dperuna
    Member
    Posted 2 years ago #

    Additional confounding issues, but probably ALL related:

    • Trying to log in or go to the admin page (www.domain.com/wp-admin) redirects on the root site, but works fine on subdomain site
    • Default permalinks work fine on the non-working sites. Changing to anything else results in the odd behavior

    Here's my .htaccess:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Part of the wp-config.php file:

    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'bstrong4life.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Note, the domain has all subdomains pointed the main directory (*.domain.com is directed to /public_html/)

  4. All those links work for me...

Topic Closed

This topic has been closed to new replies.

About this Topic