Support » Fixing WordPress » Multi-Site Admin Slow (likely db version value issue)

  • My original thread was closed, without a final solution realized. The background information is here:

    Bottom line, the upgrade process appears to have a problem modifying the db version value. I’ve been manually changing with each upgrade, but with 3.8 now in place and the problem still in existence, I’m again looking for a solution instead of a kludge. Given it doesn’t seem to be a big problem with most users, it’s got to be a local problem on my server. And now that upgrades happen automagically, I expect we’ll see more of them and I’ll be chasing this far too regularly…

    Where do I start!?

Viewing 5 replies - 1 through 5 (of 5 total)
  • No response, so I’ve been poking around when I have a few minutes. And, I think I’ve solved this.

    I added the private IP and URL to the ‘hosts’ file. This now allows the ‘update sites’ command to execute properly. And looking in the database, I can see that the db_version has been incremented properly now.

    So it would appear that some of my assumptions were wrong:

    – upgrading the WordPress version does not seem to increment the db_version, but the ‘update sites’ command evidently does.
    – the ‘update sites’ process requires the server to be able to access itself by URL, rather than simply edit the database directly.
    – the ‘update sites’ starts with the last site added, not the first as I had assumed.

    Perhaps there is more going on than I’m seeing, but from how I *apparently* solved this problem it would appear that my observations are correct. None makes much sense to me though…!

    I’ve just stumbled across this thread. I’m having problems where mine doesn’t update as well. Recently it’s started giving an error during the network update process. and I can see that many site’s are not updated to the most recent version when I look at the wp_blog_versions table. The strange thing about mine, is it’s worked just fine until the last couple updates 3.8.3 and 3.9:

    Warning! Problem updating . Your server may not be able to connect to sites running on it. Error message: A valid URL was not provided.

    Nevermind. Figured it out. First I forced the update network function to continue after the error by advancing the number on the end of the URL. After a few increases, it moved past the problem site and completed upgrading the network. I was able to see sequentially which site was giving the error. Checking it, I’d deleted all it’s tables from the DB, but hadn’t deleted it, so it was still listed in the Multisite tables. Thus there was nothing to upgrade when it came to that site. Just deleted the site, and now I’m fairly certain it will run fine.

    After that I checked the blog_versions table and the only ones that weren’t updated to the latest version, were sites that had been deleted. there were 8 or 10 of them. So I removed them from that table too. I assume my problem is solved. Hopefully this isn’t seen as hijacking, as I thought mine was related, but future people who find this thread will find something useful between our solutions.

    Hmmm. That’s an interesting solution. I’m pretty sure I created a site or two along the way that was deleted… it was my first multi-site installation so everything took place on the learning curve. My initial response to your post was that my problem didn’t happen the first time there was an update. But I may not have deleted a site yet.

    If this is in fact the cause, I wonder if this should be considered a bug? I think it is by my definition. Have you reported your findings on the bugs page?

    I will look further into this as time allows and perhaps you’ve found the solution to my problem. Thank you or posting your experience – certainly not seen as hijacking!!! 🙂

    Well, so my problem came from the fact that I’d deleted the tables for a site, but hadn’t actually removed it from the multisite. Therefore in the wp_blogs table it was still listed as an existing site on the multisite, but had no tables to be updated by the “update network” process. So when it came to that site, it threw the error and quit.

    The only possible “bug” I could see, is maybe having it handle the error more gracefully and try to skip that site and continue with the rest. Then report all errors, with more details as to which site(s) threw an error, at the very end. That would be much better. BUT the problem I was having was due to my own tinkering in the DB. Not anything WP did wrong. If I’d deleted the site through the WP Admin, it would not have happened.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Multi-Site Admin Slow (likely db version value issue)’ is closed to new replies.