Support » Plugins and Hacks » [Resolved] multi-day event not displaying correctly in widget

[Resolved] multi-day event not displaying correctly in widget

  • MC v2.1.1 on WP 3.4.2

    I can’t seem to get multi-day events to display as I’d like in the widget. I don’t know if it’s me or a bug. What I want is a single event shown in the widget with the date range, and for it to continue showing in the widget until the end date passes.

    Here is a screenshot of settings and corresponding results:
    The real site is at morningstarchiro.com

    Note that I added and deleted these events multiple times trying different settings to get it to show the way I wanted. Unless I set it as a single event recurring x number of times it erroneously shows the event multiple times, sometimes even making it a repeating event far into 2013 for some reason (not sure how I got that result, but it was interesting)!

    Please show me the way!



Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Joe Dolson


    You can set up what you want by using the ‘Add Occurrence’ button to set this up as 3 event occurrences, one for each day (29th, 30th, 31st), and check the button “This is a multi-day event”.

    What that sets up is 3 separate events, one for each day the office is closed, but groups them so that they are displayed as just one event, overriding the normal behavior of the list — which, as you have it set up, is listing each day there are events, and what event occurs that date.

    Actually, what you suggest is how it’s set up now. 3 occurrences, 1 for each day, set as a multi-day event. Look at the “Office Closed” widget at http://morningstarchiro.com

    Dec 22-26 are set as single events, recurring (not what I want, though).
    Dec 29-31 is set to the 3 occurrences of a multi-day event. It’s listed 3 times when it should only show once.

    Plugin Author Joe Dolson


    If you have 3 separate occurrences each lasting 3 days, then that’s going to show up three times. You need this to be three grouped events each lasting just one day.

    1) Add new event
    2) Set beginning date to be Friday, check ‘all day’.
    3) Add another occurrence. Set beginning date to be Saturday.
    4) Add another occurrence. Set beginning date to Sunday.

    Check ‘multi-day event’ to group this into a single display.

    You can leave the end dates blank or set them all to the same value as the beginning date. That should work for you. If not, then this is an issue fixed by an update that I’m about to release, because this does work in my test copy — this just isn’t something I’d expect to be affected by the changes I made.

    That’s how I have it set up, I think:

    Still listed 3 times, not once.
    Is this the fix you’re already working on?

    Plugin Author Joe Dolson


    Well, no, not exactly. But it’s related – and it may be a coincidental fix. I’m going to go ahead and release this update now — let me know if it fixes the problem for you.

    It’s definitely the case that you’re getting a different display using those settings than I am, and the most obvious difference is in the fact that I’m testing in the next release version.

    I just upgraded the plugin. No change 🙁

    Plugin Author Joe Dolson


    Well, that’s weird. If you could send me a support request, that would be appreciated. I’ll have to take a closer look…from what it looks like you’re doing, it should be working out.

    Just sent it off. thanks for your help.

    FYI, the MC v2.1.3 widget is still not functioning correctly on multi-day events. I just discovered that it doesn’t show anything at all if “today’s” date is within the event date range, whether “show today’s events” is checked or not. I’ve had to abandon using the feature for now.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] multi-day event not displaying correctly in widget’ is closed to new replies.