Support » Plugin: Recent Posts Widget With Thumbnails » Mulitple not working

  • Plugin doesn’t work correctly if there are multiple instances on your website.

    There is a workaround for the problem, as indicated by the author.

    • This topic was modified 4 years, 4 months ago by brbrbr.
    • This topic was modified 4 years, 4 months ago by brbrbr.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Martin Stehle

    (@hinjiriyo)

    What do you mean with “multiple instances”?

    Thread Starter brbrbr

    (@brbrbr)

    I used your plugin with elementor. with two instances of your plugin. With different settings.

    This resulted in conflicts in the public.css

    After I created to identical instances on the same page problems with the public.css remained. The file was frequently missing and had the default 75px line as last.

    Tee last might be a caching or configuration problem on my site. But the first appeared unsolvable.

    Anyhow I couldn’t track the problem quickly so I switched to a different plugin. That one allowed to disable the css generation.

    Plugin Author Martin Stehle

    (@hinjiriyo)

    So if there had been an option for disabling the CSS generation the plugin would have been fine for your case?

    Thread Starter brbrbr

    (@brbrbr)

    Yes,

    in that case the plugin would generate and show me a suggested CSS that I can use as custom CSS.

    Or the plugin generates and uses a unique ID for each instance of adresses the CSS accordingly.

    And to put another two cents in :the plugin should use inline css instead of the public.css. The small amount of code isn’t worth the round-trip.

    Plugin Author Martin Stehle

    (@hinjiriyo)

    Each post list of this plugin is wrapped by an element you can address via the ID #rpwwt-{widget_id}. That should have been solve your issue.

    Thread Starter brbrbr

    (@brbrbr)

    correct

    Plugin Author Martin Stehle

    (@hinjiriyo)

    Why did you not post your issue in the support forum? You just confirmed that you were not aware of a feature which you was looking for, but the plugin provides it. That is an issue not of a failure of my plugin, so it does not deserve a bad rating. I am upset about your action.

    Thread Starter brbrbr

    (@brbrbr)

    Hi Martin,

    Your plugin provides an ID, elementor provides ID’s. I was aware of those and no problem to work around the problem.

    still your plugin comes as recommended-by-elementor. Therefor I expect that your plugin allows (different) multiple instances out of the box, without work-arounds. Your plugin didn’t meet that expectation and that the reason for the poor rating. Maybe 2 is too low, but still.

    Plugin Author Martin Stehle

    (@hinjiriyo)

    I never claimed the plugin as “recommended-by-elementor”. It is not the fault of the plugin if a 3rd party says something incorrect about it. Again the plugin does not deserve a low rating because of that, again I am upset with your action. Please tell me the source of that recommendation (I could not find it with Google).

    Thread Starter brbrbr

    (@brbrbr)

    It’s not elementor but the theme Kale recommends it

    And agreed, your plugin does not deserve a two star rating. But still, it didn’t meet my expectations so for me it won’t be a high rating.

    having more then one instance of your plugin on a site is still an issue if the settings are not identical.

    This is not an attack on your skills or the effort you put into this plugin. It just didn’t work for me.

    regards

    • This reply was modified 4 years, 4 months ago by brbrbr.
    Plugin Author Martin Stehle

    (@hinjiriyo)

    It is really ok that the plugins does not work for you. I doubt that is a reason to give it a low rating.

    Kale does not claim the plugin as “recommended by elementor”, neither on the Theme page in the WordPress Theme library nor on the homepage on the theme author’s site LyraThemes. LyraThemes says Kale can integrate the plugin “Recent Posts Widget With Thumbnails” – which is quite another topic – and LyraThemes does not mention elementor in the case of Kale.

    It is possible to use the plugin as multiple instances with different settings in several Widget areas on the Widgets page in the backend and in the frontend of the site. It is never claimed that that works in elementor, even in any page builder. Again, that is not a fault of the plugin but a specific property of the page builder.

    You gave a 2-star rating, you stated the plugin does not deserve that low rating – but the low rating remains. I am very disappointed about your behaviour.

    Thread Starter brbrbr

    (@brbrbr)

    Kale recommends the plugin not elementor, I already corrected that mistake and I changed the rating this morning.

    i doubt that your plugin will work correctly if used with different settings on different locations, but I will not spend any more time on it

    And this is getting way to personal

    I wish you all the best with your plugin, hopefully a lot of people will find it usefull.

    Plugin Author Martin Stehle

    (@hinjiriyo)

    It’s ok now.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Mulitple not working’ is closed to new replies.