Support » Networking WordPress » MU sites have no admin panel

  • I followed the directions perfectly. The child site will show up, but when I try to go to the admin of it, it says This is somewhat embarrassing, isn’t it?

    It seems we can’t find what you’re looking for. Perhaps searching, or one of the links below, can help.

Viewing 15 replies - 1 through 15 (of 20 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    What’s in your .htaccess? Is it correct? (It’s really easy to mess that up)

    This is my .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress
    
    # secure htaccess file
    <Files .htaccess>
     order allow,deny
     deny from all
    </Files>
    
    # disable directory browsing
    Options All -Indexes
    
    # provide a universal error document
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^.*$ /dir/error.php [L]
    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    You should always put the WP calls at the bottom.

    You’re using subdomains?

    # secure htaccess file
    <Files .htaccess>
     order allow,deny
     deny from all
    </Files>
    
    # disable directory browsing
    Options All -Indexes
    
    # provide a universal error document
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^.*$ /dir/error.php [L]
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    Ohh, ok. No, I wanted folders. I wanted to create a site for my photography on my domain without having to use another wordpress install to get a different theme.

    Now it says:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@quicksilverdesigns.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Hello,

    I encounter a similar issue

    My network Superadmin dashboard has disappeared, even though it was functioning normally before today, when i installed a fresh Multisite WordPress Network in the root folder /public_html

    Me too i still have access to the normal site dashboard and the site is still live.

    I get a different error message when trying to access my Network dashboard at SITE//wp-admin/network/ :

    Fatal error: Call to undefined function get_current_screen() in …PATH/wp-admin/network/settings.php on line 22

    My code in the .htaccess file is the exact one that i copied upon install, the one in Network Setup.

    Here it is:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    I hope this helps you experts to solve the problem.

    Thanks in advance

    Betty

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Betty Donelly – Make your OWN topic please. It’s really hard to help two people in the same thread. (Basic rule: If a topic is resolved, or you don’t have 100% the same error, make your own topic.)

    QuicksilverQueen – If you wanted subfolders, first check your wp-config.php and see what SUBDOMAIN is set to. It should be false.

    if that’s done, grab the .htaccess from: http://codex.wordpress.org/Multisite_Network_Administration#.htaccess_and_Mod_Rewrite

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Yes please create your own thread, Betty — it’s really rude to take over mine with a completely different problem.

    New plan: moving the my sites to subdomains cuz it screwed with my pages, unless there’s a way to have pretty permalinks and subdirectory sites…

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    You can have pretty permalinks on subdirectory. However you WILL change the URLs of your main site’s POSTS to domain.com/blog/postname

    The main site didn’t have any posts…and its pages don’t work now either (500 error). I’m really frustrated. :-/

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    500 error is usually your .htaccess.

    Try this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    That should get you past the 500, however it would imply that mod_rewrite isn’t on for your server.

    I have Dreamhost. I checked, and it said mod_rewrite is on. That .htaccess stuff in your previous post didn’t work either.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Did it give you the error 500, though?

    Yes, it’s still a 500 error.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    *blink* That’s …

    Um.

    Okay, the reason I said to put the <IfModule mod_rewrite.c> wrapper is that it will prevent an error 500 in the event there’s somethign wrong with the rewrites (or you have mod-rewrite off).

    Use what I gave you as the COMPLETE .htaccess. Get rid of everything else. Maybe it’s not WP but some of the other code.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘MU sites have no admin panel’ is closed to new replies.