[resolved] MU 2.9.1 - WP-ADMIN/ Blank (9 posts)

  1. ironicsky
    Posted 5 years ago #

    For some reason this morning when I go to login to /wp-admin/ on any sub-blog, the /wp-admin/ is blank, while it worked fine yesterday.

    The blogs themselves work fine and the associated plugins work fine, I just cannot get in to the admin. I've tried two different computers on two different networks to rule out network proxy caches and browser issues.

    I've tried removing all plugins from the MU and regular plugins directory, which didn't help.

    PHP has not been upgraded since February, I've tried increasing and decreasing the memory limit in wp-settings and I've tried creating a php.ini and disabling Zend for my /blogs/ directory.

    I know I could probably upgrade to 3.x, but I find upgrading things break since in my environment I __MUST__ have www. in front of URL's.

    Any suggestions?

  2. blank screens = php errors. Something had to have changed.

    Did you check your error logs on the server? (thumbs up for checking plugins first)

  3. ironicsky
    Posted 5 years ago #

    Unfortunately we are on a shared hosting account and our provider is usually unwilling to provide any sort of log data outside of the apache access logs for our domains.

    Is there a way to put wp in debug mode and have it trace what its doing so I can figure out where it is going bad?


  4. Shared hosts often provide error logs. Like in cpanel.

    Yes, there's a debug mode.

    do it with all plugins turned off so there's less to wade through.

  5. ironicsky
    Posted 5 years ago #

    I put it in debug mode and followed the instructions...

    The outputted errors included

    [14-Jul-2010 15:10:26] PHP Notice:  Undefined index:  plugin in /services3/webpages/t/d/MYDOMAIN.COM/public/blogs/wp-admin/includes/mu.php on line 825
    [14-Jul-2010 15:10:26] PHP Notice:  Undefined index:  plugin in /services3/webpages/t/d/MYDOMAIN.COM/public/blogs/wp-admin/includes/mu.php on line 850
    [14-Jul-2010 15:10:26] PHP Notice:  Undefined index:  plugin in /services3/webpages/t/d/MYDOMAIN.COM/public/blogs/wp-admin/includes/mu.php on line 1059
    [14-Jul-2010 15:10:26] PHP Warning:  Cannot modify header information - headers already sent by (output started at /services3/webpages/t/d/MYDOMAIN.COM/public/blogs/wp-includes/kses.php:1) in /services3/webpages/t/d/MYDOMAIN.COM/public/blogs/wp-includes/pluggable.php on line 868

    If I comment out each of the lines listed, the errors go away but the problem does not. still a white screen.

    I disabled the cache, ran the included DB repair/optimize script in wp-admin/maint/repair.php and still no resolution.

    So I've started doing some manual debugging by throwing echo statements in to /wp-admin/index.php and each file it calls

    I've managed to trace it through

            if ( $user_id = wp_validate_auth_cookie( '', apply_filters( 'auth_redirect_scheme', '' ) ) )
               function wp_validate_auth_cookie($cookie = '', $scheme = '')
                  wp_parse_auth_cookie($cookie, $scheme)

    Which is where my echo trace seems to die and I cant figure out why. I have no cookies in Fire Fox right now... Same issue in IE.

  6. ironicsky
    Posted 5 years ago #

    I also checked the last modified on some server configs...

    /usr/local/lib/php.ini was last modified: October 15 2007 18:13:37.
    /services/apache/conf/httpd.conf was last modified: April 23 2010 06:20:11.

    And last build of Apache/PHP was: Feb 1 2010 12:21:26

    So it does not appear that anything in the server environment has changed since the problem started occuring.

  7. fresh copies of the wp files?

  8. ironicsky
    Posted 5 years ago #

    I am hating the idea, but I may have too. It'll be a pain in the butt because I have some customizations that i'll need to port (integration with third party databases)...

    But I installed WP 3.0 and it turns out they removed the annoying "strip www" __feature__ so aside from that I should be okay as long as all my plugins come over ok.

    It is really strange that random files just caused the site to die like that. I don't think I've ever had another environment just crap itself for no known reason.

  9. ironicsky
    Posted 5 years ago #

    Upgraded to 3.0 and enabled multi-site
    Migrated my customizations and everything works fine.

    Hopefully it doesn't break again :)

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.