Support » Fixing WordPress » (mt)(dv)Unable to create directory – is parent directory writable by the server?

  • Trying to upload theme to WordPress on Media Temple’s (dv). Every time I get:
    “Unable to create directory
    Is its parent directory writable by the server?”

    Similar error occurs when trying to upload photo’s through WordPress’s uploader.

    I have tried changing perms to uploads to everything… I think it has to do with Apache ownership? Possibly?

    There are many other posts like this but none resolved.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hey ludditecreative,

    Did you find a solution? I’ve just upgraded to (dv) and I’m getting the same error.. Spent hours looking around the googles but nothing so far..


    Im having the same problem. I am hosted on GoDaddy, which I have other sites on and havent had this problem. Also, I set the permissions to 777 and 755 and neither worked. It is so weird.

    I am running WordPress 3.0.1… I used to be able to upload images to this site before the upgrade, but im not sure if it is directly related because I can upload images to other upgraded sites.

    And I only have 1 plugin active (Contact Form 7). I am going to try to disable it and see if I have any luck.



    Forum Moderator

    Change the permissions on the wp-content directory to 766. If you still have problems, try 767 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

    My wp-content directory is 777 … it was 755, but since changing it to 777 last week I still do not have any luck uploading images.



    Forum Moderator

    Contact GoDaddy and ask them to check the folder ownership.

    Just got off the phone with GoDaddy and they didnt see anything on their end as far as the folder ownership issue. The one thing we did while on the phone was go into the hosting control panel and on the file manager I selected wp-content > uploads folder and checked a box to make it executable. After hitting OK, I went back to WordPress to try and upload an image and it gave me the same error.

    Then after 5 minutes in WordPress I decided to test some things. I went to Settings > Media and changed the default location to upload images to a new folder and unchecked the organize by year and month box. This allowed me to upload images.

    Then I changed it back to wp-content/uploads and kept the box to organize it unchecked. This also worked.

    Finally, I went back to the media settings and checked the box to organize by year and month back on … and this worked. So maybe it just needed a toggle of the default upload folder and organize by for it to work again? Or maybe the file manager needed extra time to work on the server?

    Either way I am back in business. Hope this helps someone.

    Word of caution to anyone using the (dv) service through Media Temple: make sure you read up on FastCGI and default Apache configurations. Because they let you manage everything on your own, there is very little support for any issues you might have. They’re a good host – just be careful and do your reading!

    I strongly advise to NOT use MediaTemple unless you have godlike Linux skills and serious IT resources for time wasting.

    Mediatemple configures their Apache service in as a different user from the WordPress. Thus, when you upload from WordPress it attempts to write to directories that have been created by Apache. And because because they are not owned in the same group you cannot write over them.While this can be ‘foxed’ by changing permissions to 777 you create security concerns.

    Media Temple have proposed a solution using fast CGI, however this causes serious memory exhaustion problems and stability issues – at just five thousand hits per day by systems my (dv) instance is running at 70% CPU. Worse, after implementing this recommended change for FastCGI, I need to reboot twice per day to keep the system running at reasonable speed.

    Media Temple tech support refuse to offer any assistance, at any time or for any purpose with relationship to WordPress. Additionally if you attempt to use support by e-mail it will take between one and three days for a response to occur-and because I am overseas I cannot use the telephone.

    Again strongly to recommend you DO NOT use media Temple for any purpose.

    @eherealmind – I strongly disagree with your assessment of MediaTemple. I get excellent customer support from MediaTemple and have had a lot of success with the service. Yes, you need to know a little more than most, but that’s a good thing. Getting your hands into understanding your systems, when you’re hosting WordPress sites, is only going to make you a better developer and system administrator. Just because you’re frustrated, doesn’t mean that it’s MediaTemple’s fault.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘(mt)(dv)Unable to create directory – is parent directory writable by the server?’ is closed to new replies.