Support » Networking WordPress » ms-files.php cause high cpu load

  • hello, i have a server whit a single procesor 4 core 2.5ghz and 4gb ram

    the load is usually between 3 and 7%, but sometimes has peaks of 100%

    http://kandombe.com/load.png

    i have a mulsite install with buddypress

    when the load has peaks you can see many processes ms-files.php

    http://kandombe.com/cpu.png

    what can be the problem, would i have to return to simple installation?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    You also have a problem with forcing www in your blog.

    http://kandombe.com/load.png doesn’t work.

    http://www.kandombe.com/load.png does.

    That’s a different issue.

    Read http://thethemefoundry.com/blog/optimize-apache-wordpress/

    You’ll get a lot of milage out of optomizing your server, as well as applying some caching. Plugins like wp Super Cache and W3 Total Cache will help.

    hi ipstenu, i’m using W3 Total Cache now

    Page Caching using disk: enhanced
    Database Caching disk: basic
    Object Caching disk: basic

    i disable buddypress but the problem still persist

    11678 (Trace) (Kill) 	kandom 	4 	
    
     23.0 	
    
     0.8 	/usr/bin/php /home/kandom/public_html/index.php
    11698 (Trace) (Kill) 	kandom 	4 	
    
     17.0 	0.4 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11696 (Trace) (Kill) 	kandom 	4 	
    
     17.0 	0.0 	[php] <defunct>
    11713 (Trace) (Kill) 	kandom 	4 	
    
     17.0 	0.0 	[php]
    11699 (Trace) (Kill) 	kandom 	4 	
    
     16.0 	0.4 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11708 (Trace) (Kill) 	kandom 	4 	
    
     16.0 	0.4 	/usr/bin/php /home/kandom/public_html/index.php
    11711 (Trace) (Kill) 	kandom 	4 	
    
     16.0 	0.4 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11714 (Trace) (Kill) 	kandom 	4 	
    
     16.0 	0.3 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11679 (Trace) (Kill) 	kandom 	4 	
    
     16.0 	0.0 	[php] <defunct>
    11684 (Trace) (Kill) 	kandom 	4 	
    
     16.0 	0.0 	[php] <defunct>
    11710 (Trace) (Kill) 	kandom 	4 	
    
     16.0 	0.0 	[php] <defunct>
    11715 (Trace) (Kill) 	kandom 	4 	
    
     16.0 	0.0 	[php] <defunct>
    11709 (Trace) (Kill) 	kandom 	4 	
    
     15.0 	0.4 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11706 (Trace) (Kill) 	kandom 	4 	
    
     15.0 	0.3 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11707 (Trace) (Kill) 	kandom 	4 	
    
     15.0 	0.3 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11717 (Trace) (Kill) 	kandom 	4 	
    
     15.0 	0.3 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11720 (Trace) (Kill) 	kandom 	4 	
    
     13.0 	0.2 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11719 (Trace) (Kill) 	kandom 	4 	
    
     12.0 	0.2 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11722 (Trace) (Kill) 	kandom 	4 	
    
     12.0 	0.2 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11721 (Trace) (Kill) 	kandom 	4 	
    
     11.0 	0.2 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11725 (Trace) (Kill) 	kandom 	4 	
    
     9.0 	0.2 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11727 (Trace) (Kill) 	kandom 	4 	
    
     8.0 	0.2 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11732 (Trace) (Kill) 	kandom 	4 	
    
     8.0 	0.2 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11733 (Trace) (Kill) 	kandom 	4 	
    
     6.0 	0.2 	/usr/bin/php /home/kandom/public_html/wp-includes/ms-files.php
    11735 (Trace) (Kill) 	kandom 	4 	
    
     6.0 	0.2 	/usr/bin/php /home/kandom/public_html/wp-cron.php
    11457 (Trace) (Kill) 	kandom 	4 	
    
     2.2 	0.0 	[php] <defunct>
    11481 (Trace) (Kill) 	kandom 	4 	
    
     2.1 	0.0 	[php] <defunct>
    11362 (Trace) (Kill) 	kandom 	4 	
    
     1.3 	0.0 	[php] <defunct>
    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    You need to optomize your server too. Change the min/max settings etc. Install APC or something similar to cache on the server side.

    I’m using a server with 1G memory, a multisite with 4 sites, and three other heavily visited sites. Nary an issue.

    thanks for your update

    how many visits do you have? i have like 50.000 whit 2 or 3 views per user

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Per day, per month…?

    50.000 unique users per day

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Added up, yes, the sites total about that. (Wow, when did that happen?)

    Averages of 4-5 pages per visitor.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Per your other post, no you can’t turn it off. It’s required to handle your images right now. When that trac ticket you found is completed we can.

    You need to do some server optimization.

    (Bear in mind, wordpress.COM uses the same setup so it can support that much traffic. You just may need a better built server)

    thanks!

    can you tell me what are the w3 total cache settings you’re using? and which version of APC?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Page Cache is Disk Enhanced, Minify is Disk (and manually selected), Object Cache uses APC, Browser Cache is on.

    APC is 3.1.9

    great, i will try with your configuration

    hello, my support has installed the APC, and i config the w3 total cache as you said

    the things, goes really wrong now :S

    http://androidzone.org/apache.png

    maybe is my server, can you tell me whats your provider ?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Like I said before, there’s a lot of server stuff you can optomize.

    Read http://thethemefoundry.com/blog/optimize-apache-wordpress/

    I played a LOT with my min/max and other settings to tune my server. And my host (Liquidweb) helped a lot.

    ok, i will have to learn
    if you know some other useful tutorials please let me know
    thanks you!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘ms-files.php cause high cpu load’ is closed to new replies.