Support » Plugin: WordPress MU Domain Mapping » MS Domain Mapping & wp-config.php

  • Resolved kategrey

    (@kategrey)


    Multisite, subdomain. When I Domain Mapping in Adminstrative settings, getting the message:

    “Please copy sunrise.php to /hermes/bosoraweb162/b535/ipg.slavequartersuscom/wp-content/sunrise.php and ensure the SUNRISE definition is in /hermes/bosoraweb162/b535/ipg.slavequartersuscom/wp-config.php”

    I have loaded the domain mapping plugin and activated network wide.
    I uploaded the sunrise.php file to wp-content plugins. It’s definitely there.
    Then I tried to alter wp-config.php folder. Here is where I messed up I am sure.
    Anyway, after a lot of back and forth the part of config.php file I was working on (and I have copied a little above it, now reads as follows:
    ————-

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define(‘WP_DEBUG’, false);
    /* Multisite */

    define(‘WP_ALLOW_MULTISITE’, true);

    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, true);
    define(‘DOMAIN_CURRENT_SITE’, ‘slavequarters.us.com’);
    define(‘PATH_CURRENT_SITE’, ‘/’);
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOG_ID_CURRENT_SITE’, 1);
    define(‘WP_DEBUG’, false);
    define(‘WP_ALLOW_MULTISITE’, true);

    define(‘SUNRISE’, ‘on’);

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);
    /* That’s all, stop editing! Happy blogging. */

    I am still getting the message:
    “Please copy sunrise.php to /hermes/bosoraweb162/b535/ipg.slavequartersuscom/wp-content/sunrise.php and ensure the SUNRISE definition is in /hermes/bosoraweb162/b535/ipg.slavequartersuscom/wp-config.php”

    If I need to fix something, not sure what or where or how.

    Please help!

    http://wordpress.org/plugins/wordpress-mu-domain-mapping/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    Check to see if the permissions on sunrise.php allow the web server to access the file.

    Thank you. Sorry but I don’t know what I am looking for to check the permissions. In the sunrise.php file or in wp-config.php? And what line?

    I can say the permission re sunrise.php is 644. Everything else relevant has the same number.

    Plugin Author Ron Rennick

    (@wpmuguru)

    Sorry but I don’t know what I am looking for to check the permissions

    The file system permissions on the file. Is the owner the same user as the other files?

    Thank you. Yes the owner was/is the same user. All are the same user.

    Anyway, ipage coded it to work without the plug in. For some reason sunrise.php was not being recognized in wp-config.php or at least if it was being recognized the error message was popping up anyway and I could not adjust settings. So somehow they recoded it, but now it works regardless. I still get an error message on the plug in — somewhat different than before.

    Sure it was my problem not yours. Occurred to me that I may be I had conflicting plugins. Before I could disable all and test that we resolved it another way.

    Issue resolved. Thank you very much for your time.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘MS Domain Mapping & wp-config.php’ is closed to new replies.