WordPress.org

Forums

mqTranslate
mqTranslate removing empty paragraphs on post update (20 posts)

  1. ritmanis
    Member
    Posted 1 year ago #

    I'm using mqTranslate with WordPress 3.9.1, which has TinyMCE 4 by default. Everything was working fine, however, when I installed mqTranslate, every time I update a post, all the empty paragraphs / line breaks are removed, therefore messing up my formatting.
    I have found several fixes on google that preserve formatting, however, none are working with the new TinyMCE.

    https://wordpress.org/plugins/mqtranslate/

  2. ritmanis
    Member
    Posted 1 year ago #

    Can anyone else confirm this problem, or am I the only one?

    I even set up a fresh installation of WordPress and installed the latest mqTranslate, and it still removes all line breaks / empty paragraphs on post update.

  3. extremecarver
    Member
    Posted 1 year ago #

    I have the same problem! (even if I disable the editor via setting:
    define('QT_MIN_SUPPORTED_WP_MINOR_VERSION', '3.8');
    define('QT_MAX_SUPPORTED_WP_MAJOR_VERSION', '3.8');

    in mqtranslate.php...

    Only if I use a very old not supported editor it works again (Deans FCKEditor for WordPress)..

    I really hate all that editor munging qtranslate or mqtranslate do. I use shorctodes and don't ever want to see a separate window per language. That makes editing impossible and painful if you have more than 2 or 3 languages activated.

    I would just love if mqtranslate doesn't mess with the editor. But well, Qtranslate did so too and with Qtranslate I also lost all empty lines (except if used together with Deans FCKEditor).

  4. extremecarver
    Member
    Posted 1 year ago #

    Now the even bigger problem with standard editor is. If you disable mqtranslate Editor, via setting unsupported Version - you also loose visual editor. Only html editor available - so that's not usable at all without switching to another editor...

    (of which only Deans FCKEditor doesn't crash my lines breaks - but therefore now has problems with another plugin).

  5. ritmanis
    Member
    Posted 1 year ago #

    Never knew about the FCKEditor workaround, thank you for the idea, I'll have to try it out.

    However, I like the system of separate tabs for every language, so for me it's essential to keep that functionality. Any way to pair this with FCKEditor?

  6. extremecarver
    Member
    Posted 1 year ago #

    Nope - all editors that show separate tabs seem to rely on TinyMCE autoformat madness...

    E.g. FolioPress shows stuff a bit different (already tries to consider the width of the page and so on), has different more extensive editing tools - but still messes up with Autoformat.

    The only working solution for me is Deans FCKEditor plugin - but that hasn't seen an update since years - so I wonder for how long it keeps working (just noted some bugs on a badly programmed payment plugin - though that's the first time I ran into a bug with it).

    Yeah - and the other solution is to disable visual editor and use html editor. But no thanks - that not my cup of tea for general use.

    Edit - well: http://ithemes.com/2012/03/30/security-alert-deans-fckeditor-with-pwwangs-code-plugin-for-wordpress/

    means actually don't use Dean's - security hole. Now that's getting messy for me...

  7. ritmanis
    Member
    Posted 1 year ago #

    Well, hopefully chsxf will look in to this problem.

  8. mic0000
    Member
    Posted 1 year ago #

    yes,
    if you have a solution with the native editor tinyMCE it will be better!
    Thank you again, this plugin is great, but the deletion of empty paragraphs is really annoying ...

  9. chsxf
    Member
    Plugin Author

    Posted 1 year ago #

    I have resolved this bug tonight and the fix will be available in the next release of mqTranslate (2.6.6). I hope to release it by the end of the week.

  10. Astha44
    Member
    Posted 12 months ago #

    Hi guys,

    i'm curious to know if it has been fixed or not ?

    I downloaded mqtranslate 2.6.6.3 today, and i seem to have the same problem. It destroys the layout of my pages. On some pages it's not that hard to correct but on the homepage it's a pain in the neck.

    Thanks

  11. Flyh
    Member
    Posted 12 months ago #

    Hey. I also got the same problem. When I change the editor from English to French, I loose all the HTML layout on the editor.
    Did you find where this is coming from?
    Thanks

  12. janbuckuliak
    Member
    Posted 11 months ago #

    a had the same problem. I installed TinyMCE Advanced https://wordpress.org/plugins/tinymce-advanced/ and checked "Stop removing the <p> and
    tags when saving and show them in the Text editor" in Advanced Settings and it works for me.

  13. Astha44
    Member
    Posted 11 months ago #

    Thanks janbuckliak,

    it seems to be a bit better but the </br> are still beeing removed. I haven't found a solution so far, even though i tried a couple of ideas such as commenting out the line 120 in the mqtranslate_wphacks.php file, doesn't work.

    Does anyone have other ideas ?

  14. papagoejoe
    Member
    Posted 11 months ago #

    Any update on this issue. Still having it with WP 3.9.2 and mqTranslate 2.6.6.3.

    It doesn't seem to happen every time, but most.

    Thanks for the great work!

  15. Petluck
    Member
    Posted 11 months ago #

    This is still occurring. WP 3.9.2 and mqTranslate 2.6.6.3. Worse than ever since the fix. Time consuming to keep going back and fix formatting all the time.

    thanks! otherwise works well.

  16. chsxf
    Member
    Plugin Author

    Posted 11 months ago #

    I just released version 2.6.7 which should fix this bug completely.
    All our tests succeeded without exception.
    Let me know if everything is OK for you know.

  17. paolinov
    Member
    Posted 11 months ago #

    Grat, TinyMCE Advanced fixed my problem.
    Thank you.

  18. Astha44
    Member
    Posted 11 months ago #

    chsxf : Congratulation for the great work, the bug is fixed, it works!!!

  19. marekwozniczka
    Member
    Posted 7 months ago #

    This is still occurring.
    WP 4.0.1 and mqTranslate 2.9

  20. fafa77
    Member
    Posted 7 months ago #

    Yes, i have same problem, WP 4.01 and mq Translate 2.9 ; every time I update a post, i messing up my formatting in 2nd language field; 1
    st one doesn't change, but in 2nd one language section white spaces are added below each line

    for example , if in 1st language is written:
    aaaaaaaa
    bbbbbbbb

    in 2nd language section become when i try to edit a post
    aaaaaaaa

    bbbbbbbb (of course in another language:)

    Please fix it , can't imagine problems who have more than 2 languages,,

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • mqTranslate
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic