WordPress.org

Support

Support » Plugins and Hacks » mqTranslate » [Resolved] Mqtranslate BREAKS Language Shortcodes e.g. [:en] or [:de]

[Resolved] Mqtranslate BREAKS Language Shortcodes e.g. [:en] or [:de]

  • First, I was really happy having found a replacement for Qtranslate, however it seems mqtranslate really fucks up my editor. I’m using an old version of FCKEditor – because I cannot stand having those separate language fields and all that bloat.

    All I want is to enter [:en] or [:de] or [:es] and so, I don’t want no crazy <!–:en–> … <!–:–> full tags which are only visible in html editor mode

    Please make it possible to shut of that automatic stuff. It completly runs havoc, adds additional lines, breaks my format and so on.

    So far for me my only solution is to move back to qtranslate. Mqtranslate with that editor is a nogo for me…

    https://wordpress.org/plugins/mqtranslate/

Viewing 7 replies - 1 through 7 (of 7 total)
  • ups forgot to say – mqtranslate simply replaces them, and doesn’t do it correctly. I end up having a complete mix up…

    Plugin Author chsxf

    @chsxf

    I’m pleased to tell you this bug has been resolved and the fix will be available in the next release coming before the end of the week-end.

    Thanks – it’s mainly working now. However for titles without any language tags, it still adds them. Why can there be no setting to use mqtranslate without ANY editor changing.

    Just leave any editor or changes alone – add a mode that gets rid of any frontend changes except the settings.

    Then one can use shortcodes for everything simple, write Text like

    Language 1
    Language 2
    ALL LANGAUGES
    Language 1
    Language2

    using the full language codes in html editor. That saves plenty of reduplication if you can for example post instructions in each language – then a long link list or pictures without any langauge (meaning the show in every language) – then go back to translated parts – instead of having everything for each langauge separate…

    Best would be if there could be [/:en] language exit shortcodes… Then one could even stay in visual editor without html editor.

    Fully getting rid of editor changes would make mqtranslate also a much slimmer and less breakable plugin…

    i use this in widget
    [:en]Popular[:fr]Populaire
    Cool it’s working
    Thanks for mqTranslate

    WP mineworks

    @wpmineworks

    @donotdont Thanks for the tip, that works 🙂

    this shortcode unknown when i send mail from backend. how can i do?
    i use it with this plugin “https://wordpress.org/plugins/restaurant-reservations/” for send mail confirm from backend.

    extremecarver

    @extremecarver

    Well yes – anything that would work for the email backend would be great. But so far nothing works there (at least when I checked couple of years ago – but I don’t think there were any relevant changes).

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Mqtranslate BREAKS Language Shortcodes e.g. [:en] or [:de]’ is closed to new replies.
Skip to toolbar