Support » Plugin: Easy Updates Manager » MPSUM_Tracking::send()

  • Resolved Vicky

    (@vickymedrano)


    It seems to be some unathorized data collection scheduled in my cron jobs; Hoock name: eum-monthly, actions: MPSUM_Tracking::send() to keen.io
    It used to be an option in the advanced settings to opt out the data collection but now it seems to be a forced built in feature.
    I looked at the MPSUM_Tracking.php script and it seems to be collecting plugin options data and filtering out email addresses “unset( $options[ ’email_addresses’ ] )” but I’m not sure, is that so?. I wish you’d give us the choice to enable or not this feature.
    Appart form this, the plugin is excellent.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Ronald Huereca

    (@ronalfy)

    The data tracking should be opt-in, as we’d be violating the guidelines here.

    We’ll investigate.

    Plugin Contributor Ronald Huereca

    (@ronalfy)

    @vickymedrano,

    I did find a bug in reset options that prevented a cron job from being cleared, which I will try to fix shortly.

    Aside from that, I can’t at this moment find any reason through code inspection and testing why your EUM copy would add a cron job without the user saying it’s okay.

    In the mean time, you can install WP Crontrol to remove the errant cron job.

    Plugin Contributor Ronald Huereca

    (@ronalfy)

    We just released version 6.4.4 which should have the option for removing tracking.

    If you find any other instances of being opted-in without permission, please let us know. This shouldn’t be happening.

    Vicky

    (@vickymedrano)

    Hi Ronald,

    Thanks soooo much for your quick and thoughtful replies! you’re awsome!! 🙂
    I didn’t get notified by email about your comments in this thread… but I noticed on the 6.4.4 update the issue about the tracking had been fixed, so I came back to post an update on this comment, and to thank you 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘MPSUM_Tracking::send()’ is closed to new replies.