Support » Fixing WordPress » Mp4 Media error: Format(s) not supported or source(s) not found

  • Tried uploading an mp4 video in the Twenty Seventeen theme and got the error message: Media error: Format(s) not supported or source(s) not found.
    I created the mp4 on a Mac by exporting a quicktime movie to MPEG-4 with these settings – Data Rate 333 kbits/sec, frame rate 30, key frame: every 12 frames, re-sync markers. Also tried using HandBrake to create the mp4.

Viewing 13 replies - 1 through 13 (of 13 total)
  • lisa

    (@contentiskey)

    what is the file size of the video you are trying to use?

    6.2 MB (max limit is 8 MB)

    lisa

    (@contentiskey)

    have you tried to load video via FTP?
    (you will likely need the plugin Add From Server https://wordpress.org/plugins/add-from-server/ )

    I want to stick with the default uploading method for theme 2017, which has worked in the past with other mp4 files. There’s something different about the one that failed but i can’t figure out what it is.

    I’ll try the 2017 theme forum

    well, after SSL installed, the same issue occurs with only Safari on my site, but videos play well in Chrome and firefox, any suggestion?

    Alex

    It is wordpress bug, please check here:

    https://core.trac.wordpress.org/ticket/42874#comment:8

    Alex

    • This reply was modified 1 year, 5 months ago by  alexlii.

    I’m also getting this error:

    Media error: Format(s) not supported or source(s) not found
    … and a link like this
    mejs.download-file: http://trumpetstudies.com/wp-content/uploads/2018/03/Concone-Ex-17.mp4?_=1

    None of my media files will play. Or, the site can’t even find them anymore.

    I was trying to update an old version of my videos with a new version, and discovered there’s not an easy way to do that in WP. I wound up restoring from a backup, and then installing Enable Media Replace. Only to discover that even that way the videos are getting the same error.

    Is this something that can be fixed in the next update? Or, should I consider a different CMS? My site is built on mp4 videos, and the user experience is ruined if they can’t be played. 🙁

    It’s a lot of work for nothing if this can’t be straightened out.

    The same problem!
    I have Impreza premium theme. Last year everything were working. But after one of the updates, mp4 stop playing with error “Format(s) not supported or source(s) not found”. (Unfortunately, I didn’t catch the moment after which mp4 was broken)

    Now I’m to use plugin Videojs HTML5 Player for posting mp4 video.
    It’s so sad!

    The same problem!
    About a year ago I’d put mp4 video links from Dropbox on my pages. And recently I noticed that video doesn’t work anymore.

    I inserted the video through the shortcode [video]:

    [video mp4="https://www.dropbox.com/s/qxrvczl8epvphyg/%D0%9F%D1%83%D1%82%D1%8C%20%D1%81%D1%82%D0%B0%D0%B6%D1%91%D1%80%D0%B0.mp4?raw=1" poster="http://csc-academy.ru/wp-content/uploads/2016/11/put-stazhera.jpg"]

    It doesn’t work in front-end. Even video block is absent.

    It seems that it happens because of link format: “?raw=1” at the end of url.
    Because when I remove “?raw=1” parameter, a video box appears, but with error «Media error: Format(s) not supported or source(s) not found»

    Now I’m to use plugin Videojs HTML5 Player for posting mp4 video.
    It’s so sad!

    I’m using DIVI. It’s not only not working with Safari. Also with Google Chrome. And it’s annoying. Is there anything new when this will be fixed?

    I had the same problem with an mp4 file only on Safari. I fixed it by rather than use the wordpress media library, I uploaded it to Vimeo and used that url and now it is fine.

    Has there been an update to this issue, or any fixes within the wordpress ecosystem? My users are in China so Vimeo and Youtube are non-options. I checked the core trac and it’s reading “under review” which could mean anything

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Mp4 Media error: Format(s) not supported or source(s) not found’ is closed to new replies.