WordPress.org

Support

Support » Plugins and Hacks » [Resolved] MP4 front-end upload issue: video thumbnail created but converted video missing

[Resolved] MP4 front-end upload issue: video thumbnail created but converted video missing

  • Hi,

    I’m using this plugin to let guest post via front-end.
    My issue is: guest can upload, and the video thumbnail is generated and stored in my wordpress upload directory. The wordpress post is also created but the actual MP4 generated video file is missing – I can’t find it anywhere in my webserver although the wordpress Media library has an entry for it
    You can find an screenshot of the related wordpress media library here
    http://twitpic.com/e4bt01

    Any clue how to address it?
    Thank you

    Hery Zo

    https://wordpress.org/plugins/wp-video-posts/

Viewing 15 replies - 1 through 15 (of 33 total)
  • Plugin Author AlexRayan

    @alexrayan

    Hi Hery,

    How are you?
    Thank you for using our plugin.

    From what you wrote seems like ffmpeg configuration issues with the flags passed. Without actually testing on the server it would be difficult to guess which flags are failing. Most common one is -vpre which is video preset. Try setting it to “none” under Settings. Also, make sure you have both libfdk_aac and libx264 available for ffmpeg or pass any other video and audio libraries you have available in the Settings.

    Do you have ssh access to your server? Could you run the conversion code from /classes/wpvp-core-class.php line 275 in command line?

    I could do that for you if you email me with credentials to alex @ alexiz.com.

    Please let me know if it helps.

    Best regards,
    Alex

    Alex I have exactly the same problem.
    You seem so helpful I am willing to tell you or do what you want. From the feedback it seems we are several to run into the same issue.
    I have used another plugin with ffmpeg and it worked like a charm. So I can do something. Your plugin has the extensions i am looking for and it allows for font posting so I want to make this work.
    Currently I am testing a blank site to solve this problem.
    Thanks in advance if you can come back to me.
    Cif

    Plugin Author AlexRayan

    @alexrayan

    Hi Cif,

    How are you?

    Sure, I can help you with the issue. So the thumbnail is being generated for you but the video is not converted, right? Could you please email me to alex @ alexiz.com with the url and admin access credentials to your current testing site?

    It seems the flag configuration issue with ffmpeg in the plugin.

    Best regards,
    Alex

    Hello Alex and thanks a lot 🙂
    I am good yes.
    The thumbnail is generated and the video is present in the media library.
    But the link of the video in the media file is nonexistent. The video is not there on its own file.
    And I can see from the feedback this happens in many cases.
    I really think the best is I give admin access.
    I just did a fresh reinstall.
    I am going to repeat the issue a couple of time.
    And send you admin access at your gmail address.
    Thanks again and best greetings from Marrakech 🙂
    Cif

    Hello Alex.
    So this is a fresh install. No settings changed really.
    I have the same happening.
    To make it more clear.
    http://alex.kby.li/wp-content/uploads/2014/08/Rehab-Success-Amber1.mp4
    That video is having thumbnail and is listed in the library but the link is 404.
    Check your gmail for admin access details.
    Thanks again.
    Cif

    Plugin Author AlexRayan

    @alexrayan

    Thank you Cif,

    I’ll check it out as soon as I can.

    Best regards,
    Alex

    Plugin Author AlexRayan

    @alexrayan

    Hi Cif,

    How are you?
    Could you please do me a favor and copy paste the configuration line of ffmpeg?
    You can get it by typing “ffmpeg” in command line. It should look similar to the following:
    configuration: --prefix=/root/ffmpeg_build --extra-cflags=-I/root/ffmpeg_build/include --extra-ldflags=-L/root/ffmpeg_build/lib --bindir=/root/bin --extra-libs=-ldl --enable-gpl --enable-libass --enable-libfdk-aac --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-nonfree --enable-pthreads --enable-vdpau --enable-bzlib --enable-libopenjpeg --enable-zlib --enable-postproc --enable-swscale --enable-x11gr

    What we’re looking for are these two libraries: libfdk-aac and libx264. They are required for the plugin to do encoding correctly.

    If they are not present in your configuration, it means that either some alternative libraries should be present for mp4 encoding (for example, libfaac) or you would need to recompile ffmpeg with the above libraries.

    Best regards,
    Alex

    Hello Alex I am fine thanks.
    I assume I get this done by my host.
    See you shortly.
    (kindly note that I get good results with
    Video Embed & Thumbnail Generator doing same kind of job on similar servers)

    Plugin Author AlexRayan

    @alexrayan

    Hi Cif,

    I actually ran shell_exec on your server to get the output myself: configuration: --prefix=/usr --enable-shared --enable-gpl --enable-version3 --enable-nonfree --enable-pthreads --enable-x11grab --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libdc1394 --enable-libfaac --enable-libmp3lame --enable-libopenjpeg --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-zlib libavutil

    You have to specify libfaac as your audio library instead of default passed libfdk_aac since this is what you have.

    Also, I set -b:a and -b:v options (audio and video bit-rate) to an empty string since your configuration doesn’t support these options.

    I tested the encoding and it’s working now.

    Best regards,
    Alex

    AWSOME !!!
    I go check !
    Thanks a lot.

    Yes thanks a lot it works – I am now testing 3gp which I am very excited about.
    For info here is the output of the server

    ffmpeg version 0.7.13, Copyright (c) 2000-2011 the FFmpeg developers
    built on Apr 1 2013 12:12:33 with gcc 4.4.7 20120313 (Red Hat 4.4.7-3)
    configuration: –prefix=/usr –enable-shared –enable-gpl –enable-version3 –enable-nonfree –enable-pthreads –enable-x11grab –enable-libopencore-amrnb –enable-libopencore-amrwb –enable-libdc1394 –enable-libfaac –enable-libmp3lame –enable-libopenjpeg –enable-libtheora –enable-libvorbis –enable-libx264 –enable-libxvid –enable-zlib

    Alex why is the splash never displayed over the video player itself leaving the latter displaying a black screen ?
    Why does in the post the splash image displays above the video player when I check : “Display splash image” OFF (and why does it always check itself back ON ?
    And why am I always made to use flowplayer when I always select video js player ?

    Plugin Author AlexRayan

    @alexrayan

    Hi Cif,

    I can see in your WP Video Posts settings that the video js is selected on your test site. And the display splash image should be ON if you want the splash image to show, which you currently have on:
    http://alex.kby.li/test-video/

    I can also select / deselect any of the options just fine under Options => WP Video Posts and they don’t revert back to the previous state.

    Regarding the splash image showing above the video, it happens due to the WordPress template displaying a featured image there and splash image is assigned to the video posts as a featured image. If you don’t want the image there, you would need to modify your template file for a single post.

    Best regards,
    Alex

    Sorry no. I try to make myself more clear.

    Alex why is the splash never displayed over the video player itself leaving the latter displaying a black screen ?
    This means everytime I use a video player it display an image over the black video player screen. It is usually called a poster and it is pasted over (not above) the video screen. It uses a thumbnail that is one picture of the movie or the first intro picture. You do not have that on any video – why not ?

    Why does in the post the splash image displays above the video player when I check : “Display splash image” OFF (and why does it always check itself back ON ?

    The splash image which I personally identify as video poster is a standalone picture above the black screen. You have an option that says : “Display splash image”. And here is what happens when I check this OFF. It anyway, in any case paste it above the screen. And when I check back in the options I see everytime the check back in that same option.

    And why am I always made to use flowplayer when I always select video js player ?

    The very same here. I select video js and every time in every case it anyway uses the flowplayer.

    Let me know if you understand that or if not clear.

    Plugin Author AlexRayan

    @alexrayan

    Hi Cif,

    Thank you for the clarification.

    Let me address each point one by one.

    Q. “…why is the splash never displayed over the video player itself leaving the latter displaying a black screen ?
    This means everytime I use a video player it display an image over the black video player screen. It is usually called a poster and it is pasted over (not above) the video screen. It uses a thumbnail that is one picture of the movie or the first intro picture. You do not have that on any video – why not ?”

    A: The splash image is passed in the shortcode: [wpvp_flowplayer src=http://alex.kby.li/wp-content/uploads/2014/08/clipcanvas_184348_offline.mp4 width=540 height=360 splash=http://alex.kby.li/wp-content/uploads/2014/08/clipcanvas_184348_offline.jpg]
    It is automatically generated on video conversion from a video frame. You can specify a number of seconds from which the frame should be generated.

    The way video js and flowplayer work is placing the splash image above the video object. This is something that’s done by these js libraries.

    If you check “Display splash image”, it will show a slash image with a button above on video container.

    Q: “The splash image which I personally identify as video poster is a standalone picture above the black screen. You have an option that says : “Display splash image”. And here is what happens when I check this OFF. It anyway, in any case paste it above the screen. And when I check back in the options I see everytime the check back in that same option.”

    A: Regarding the black screen, I think I know what the issue was. I changes preload option on video js player from none to auto, so it won’t stay as black screen anymore, but rather will preload the 1st frame of the video.

    I unchecked “Display splash image” and you can see that the post has preloaded the 1st frame instead: http://alex.kby.li/test-video/

    Q: “Why does in the post the splash image displays above the video player when I check : “Display splash image” OFF (and why does it always check itself back ON ?”

    A: I cannot replicate this behavior on your site. When I uncheck “Display splash image” and save options, it stays unchecked. If I check it and save options, it stays checked.
    Could it be that we both were performing testing on your site at the same time and I checked the option after you unchecked it? : )

    Q: “And why am I always made to use flowplayer when I always select video js player ?
    The very same here. I select video js and every time in every case it anyway uses the flowplayer.”

    A: I think the shortcode name might have been confusing here. The shortcode does says “[wpvp_flowplayer]” but it’s just the naming that was adopted before we had added the 2nd player option and was not changed, so please pay no attention to it. If you inspect the source code of the page with a video you will see that it is in fact using video js instead of a flowplayer and if you switch to a flowplayer, you will notice that it’s a different looking player.

    Hope it helps.

    Best regards,
    Alex

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Resolved] MP4 front-end upload issue: video thumbnail created but converted video missing’ is closed to new replies.