Support » Fixing WordPress » MP3 wont upload to wordpress

  • I keep trying to upload my podcast mp3 to wordpress and it wont upload, i keep getting the “Unexpected response from the server. The file may have been uploaded successfully. Check in the Media Library or reload the page.”…. now the media is no where! its not even on my hosting website. ive used filezilla to import but it wont play on the platforms…i am lost and really need some assistance

Viewing 11 replies - 16 through 26 (of 26 total)
  • @carcar8 there’s probably one setting blocking/limiting the upload of bigger files. It looks there is no universal solution.
    You can disable all other plugins and see if that helps. Then enable one by one again to see which one is causing the problem.
    You can also check server limitations.

    • This reply was modified 1 month, 3 weeks ago by romancretnik.

    Definitely try to Incognito browser method I mentioned before. It works for me every time, which probably indicates some issue with the user session.

    wuxmedia

    (@wuxmedia)

    This was, for me, an issue with the nginx configuration (reverse proxying to WP) – I checked the nginx logs, which displayed “client intended to send too large body” which pointed to the config for nginx.conf:
    client_max_body_size 4M;

    If you can tell your hosting that – they should be able to at least look at making it a bit bigger

    decentris

    (@decentris)

    Are there any updates so far? I got the same problem.

    Got a dedicated machine with ubuntu / apache / mysql and correctly set php.ini to 256M max-upload size. Also I increased memory-limit to 1024M and post-max-size to 512M, which should be sufficient to upload an 150M MP4 video-file. Also I increased max_execution_time, max_input_vars and max_input_time to 5000.

    But still this annoying “Unexpected response from the server”-error when I try to upload a file bigger than 128M.

    There is no global setting for upload size in the server-config and I am using only a WAF from Stackpath, which doesn’t limit the upload limit (tested it by redirecting to the original-IP via local hosts-file)

    As it is an “apache2”-webhost and no nginx, I have not got the option with the “client_max_body_size”-parameter.

    So I am at the end of my knowledge.

    Maybe some of you guys has discovered something to solve this.

    Hey, @decentris and everyone, Tuxedo Big File Uploads plugin solved this for me by uploading files in pieces instead a full load.

    romancretnik

    (@romancretnik)

    @decentris did you try to disable all plugins and then make an upload? That way you can see if any of the plugins makes a restriction. That was my case with All in one security plugin…

    Thanks @chrisdlc119 your suggestion worked for me too. However, this appears to be something in the core configurations or a defect. Far too many people have this issue and from what I can tell, WordPress is not behaving as expected. I’ve modified all of the configs and the upload size limit clearly shows on the new media panel that the updates are in place. Yet this error persists. Tuxedo is a good workaround. Banging my head against the wall on this got kinda old. Much appreciated.

    Kasia

    (@kasia_codeword)

    Just chiming in that I have this problem as well. Health Check comes back perfect. After speaking with hosting/server tech support, they say PHP is properly configured and there is nothing on the server impeding the uploads and that there are no errors in the server log. The Tuxedo plugin does solve it, but this is clearly not a permanent or long-term fix. WordPress should be able to support these uploads without needing a separate plugin.

    Glad to help! Hopefully WP will solve this issue, since it doesn’t seem to be related to the hosting setup.

    adejones

    (@adejones)

    @romancretnik you absolute legend, been scratching my head over this for ages but saw your post and realised I have exactly the same security. Disabled the protection, uploaded the file successfully and re-enabled.

    Thanks!!

Viewing 11 replies - 16 through 26 (of 26 total)
  • You must be logged in to reply to this topic.