WordPress.org

Forums

[resolved] MP3-JPlayer POP OUT mode? PLAY IN GROUPS mode? (12 posts)

  1. piccs3o
    Member
    Posted 4 years ago #

    Using this plugin and liking it very much.It is easy to setup and customise and it is working well for me.

    I have two questions on a couple of capabilities that would be nice to have

    I am running Buddypress and so I have Groups and Forums .The MP3-JPlayer plugin drops the playlist for these 'pages' so I am guessing there is a change in how the script is being handled in Buddypress.I will post a question in Buddypress as well but include it here just in case WordPress users of MP3-JPlayer have experienced anything similar with other plugins effecting the MP3 player.

    Second question concerns continuos play. currently when you navigate from a page the stream comes to an end. It would be good to have a pop out mode a little like StreamPad so the music playback continues un-interrupted.

    Can anyone point me in the right direction for the scripts to achieve this?

    Thanks for reading so far!

  2. simon.ward
    Member
    Posted 4 years ago #

    Hi Steve,

    there's a pop-out player in the upcoming version 1.5 (and a load of other new stuff). I'm trying to finish up right now and should be no more than a week or so away from beta testing if all goes well.

    I'm not sure about Buddypress, i'll need to look into it, do you have a link to the site as i may be able to spot something in the source?

    Simon

  3. piccs3o
    Member
    Posted 4 years ago #

    Hi Simon, thank you for the fast response and that sounds excellent,I am very happy to wait for v1.5.

    Here is the link to the site, it's in alpha mode at the moment with a tonne f work still to do.

    http://www.irrilium.com/SecretPlan

    The following pages are working fine

    Home
    SP News
    FAQ

    I think this is because they are 'pure' pages and act just like conventional WordPress pages. I am having trouble with Groups, Forums,SPGigs, and Marketplace and the Activity stream which is called SP Wall. These 'pages' are Buddypress derived and collate information from various Buddypress modules. There are several Buddypress specific Loops that are activated to collect and present the information.

    As you will see, the player is present but the playlist isn't which suggets to me it's falling outside the scpe of the Buddypress loops.

    Thank you for offering to have a look Simon, really appreciate the effort.

  4. simon.ward
    Member
    Posted 4 years ago #

    Hi Steve,

    everything is getting built but the scripts are not being added on buddypress pages, i'm not sure why. Can you turn on the 'add diagnostics to footer' on the player settings page (under template tools), and i'll look again. I'm guessing this won't be too hard to fix.

    Simon

  5. piccs3o
    Member
    Posted 4 years ago #

    Hi Simon, sorry for the delay but I have been delayed at work.

    I have turned on the function as requested.

    If you're developing a theme using the player's template-tags then these options can help out.

       Add debug output to the browser's page source view
             (info appears in the page source view (CTRL+U on most browsers), and is not visible on the site).

    Is on now !

    Do you need either of these?

       Enqueue player scripts on all site pages
             (normally scripts are only requested when they're needed by a page or widget)

       Ignore player template-tags in theme files
             (this ignores the mp3j_addscripts(), mp3j_flag(), and mp3j_put() tag functions)

  6. simon.ward
    Member
    Posted 4 years ago #

    Actually Steve, yes if you turn on 'Enqueue scripts on all pages' it would prob be ok, though it's not a good permanent solution as it means slapping my scripts on every site page.

    But i see another potential problem coming from the buddypress-group-css plugin, it's using jqueryUI but doesn't use the available WP includes that break UI into core and components, so it's going to get loaded twice. There's also an error my side here, i'm using the right filenames for the UI bits i use, but have been enqueuing them incorrectly so far, it's fixed in the upcoming release (for both wp3.1 and previous) but still it will not fix the conflict that's going to occur here with the buddypress-group-css plugin.

    could you try deactivating that one and turning the player scripts on, just to check it will work with buddypress itself and the sitewide widget plugin?

    Simon

  7. piccs3o
    Member
    Posted 4 years ago #

    Hi Simon,

    Response time is slow here because I am working a Singaporean project and a US project at the same time so have no time for the important stuff like this!

    I will deactivate the buddypress -group-CSS plugin and activate the enque scripts switch In the next five minutes.

    I have also upgraded to WordPress 3.1 and BP 1.2.8 as well which I hope will help.

    Best

    Steve

    P.S.

    Just to add that that enque scripts sorted the problem for now and that gets me going again.Happy to wait until you have completed your upgrade for any further fixes as my site will be in Alpha for a while.

    Love the little dude, great plugin!

  8. simon.ward
    Member
    Posted 4 years ago #

    Thanks for letting me know Steve.

    Simon

  9. plaine
    Member
    Posted 3 years ago #

    Just curious, is this plugin still supported? I like the idea of a pop up playlist player, but wasn't sure if that feature was still in the works or not. Thanks,

  10. simon.ward
    Member
    Posted 3 years ago #

    version 1.7 is now up and has a pop-out player
    Simon

  11. piccs3o
    Member
    Posted 3 years ago #

    Just to add for anyone who looks at this thread that the upgrade to this plugin works very well. I was looking for a media player for some time with this degree of ease of use and ability to customise functionality and look and feel. Nice job!

  12. somethingelse
    Member
    Posted 3 years ago #

    hi
    i'm trying to use this plugin - generally it works nice & smoothly... however, what i'm finding is that if click the popout player, a) the window that opens is tiny, and b) when user changes pages, the widget-based player restarts and plays OVER the popout player, so we get a layered, duplicate sound...

    obviously we'd like to keep the autoplay option so the music starts upon arrival (it's a band site, so it's appropriate), and the popout player is exactly what we want, because it's super annoying for the music to start over when changing pages...

    any suggestions how we can fix these two small issues?
    we're using WP 3.3.

    oh, also, i'm having trouble with the CSS, the player controls bar in the widget is a bit out of whack (shows up fine in the popout, once the window is expanded to fit)... not sure WHY, but any insight would be appreciated.

    website is http://www.deepseagypsies.com

    thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic