Support » Installing WordPress » moving to 3.2.1: backup file converted from .sql to .xml in myphp, not accepted

  • Hello,

    Am facing a slightly complicated problem (know close to nothing of coding)

    I had backed up my blog posts in .sql format. (This was probably version 2.8 of WP)

    After a lot of struggle(which involved installing and running XAMPP and editing the dump file), I was able to import my .sql file in myphp and get an export in .XML format.

    When I tried to import this using WP importer plugin, I was unable to do so. I got the following message:

    Sorry, there has been an error.
    This does not appear to be a WXR file, missing/invalid WXR version number

    Is there any way in which the XML file generated from a .SQL file be read by WordPress and imported correctly?
    Really appreciate any help…

Viewing 11 replies - 1 through 11 (of 11 total)
  • esmi

    (@esmi)

    Forum Moderator

    The importer uses an .xml file – not an .sql file. You will need to restore your .sql file into your WP 2.8 database manually.

    Hi Esmi

    Thanks for your response.

    1. I exported the .sql file into .xml format and then tried to import it in wordpress using wordpress importer

    2. I tried to import the .sql file into PHPMyAdmin, using its import function but was unable to do so. First, there was a problem of information_schema, which I solved by removing references to information_schema in the backed up .sql file.

    When I try to import this file, I get an error message saying:

    #1007 – Can’t create database ‘DATABASE NAME’; database exists

    I cannot delete this database from PHPMYAdmin. (I tried to use DROP DATABASE command, but that was not allowed.) I cannot see this database in my mySQL databases list.

    I am certainly not a programmer or coder. It took me a lot of googling and dangerous trial and error to reach this stage itself. So, it would be great if you explain in detail as to exactly what and how I need to proceed. I would highly appreciate it.

    Thanks again.

    esmi

    (@esmi)

    Forum Moderator

    You cannot create the .xml file yourself. WordPress needs to do it. All I can suggest is that you try googling to see if anyone has built an application that can convert an .sql file into a WXR/XML WordPress file.

    I do not see any such application and frankly, am running out of time.
    Am not able to import into Phpmyadmin, neither into wordpress…is there no way to fix this?

    esmi

    (@esmi)

    Forum Moderator

    You cannot import anything other than a WordPress WXR .xml file into a wordpress.com site.

    Hi,
    I was able to import the database file (.sql file) using PHPMyAdmin, by making some edits ni the .sql file.

    However, while importing, all the tables have been put into another database and not in the new database (the new database is called wp321, which has the tables of wordpress installation ver 3.2.1. The sql file, when imported, created a DB called wdrp1, which contains the tables for wordpress 2.8. I cannot delete the database called wrdp1).

    So, my old entries and comments are not seen on my website. How can I include these entries, so that my blog can go up online again?

    Thanks a lot!

    esmi

    (@esmi)

    Forum Moderator

    Do you have access to your old blog? If so, what version was it running?

    I am not completely sure, I think it was 2.8.
    I do not have access to the old blog. I only have a backup copy. Had tried to install 3.2.1 by automatic upgrade, but it created errors, so to get the new version, I took a backup and deleted the old version.

    esmi

    (@esmi)

    Forum Moderator

    Try looking in the wp-options table dump in your backup file for db_version. The value for that field will help us to identify which version of WordPress you need to install for that database.

    Hi,
    Sorry I just moved into a new job, so was busy.

    The value is 17056, which makes it version 3.1, not 2.8, that was an error.

    (57, 0, ‘db_version’, ‘17056’, ‘yes’),

    Why make so complicated?
    Just create a new DB using PHPmyadmin.
    Install WP 2.8 using that DB
    import your SQL in that
    Update the WP to 3.2.2

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘moving to 3.2.1: backup file converted from .sql to .xml in myphp, not accepted’ is closed to new replies.