moving sql database from one server to another 1and1 (10 posts)

  1. kevnolan
    Posted 4 years ago #

    I have two hosting packages with 1and1.co.uk and I have being trying to move my wordpress blog from one package to another.

    When I try to import the database I get the following error:

    SQL query:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    It also seem to conflict with silverstipe aswell.

    Silverstripe is installed in the main directory (www.kevnolan.co.uk
    and my wordpress blog is (www.kevnolan.co.uk/travelblog)

    And for some reason when I click the link: http://www.kevnolan.co.uk/travelblog/wp-admin/install.php

    it shows the silverstripe site.

    Can any one help wit my moutain? I can imagine people to people out there it is a mole hill :)

  2. esmi
    Forum Moderator
    Posted 4 years ago #

  3. kevnolan
    Posted 4 years ago #

    Thanks for the reply. Are you able to elaborate? I've had a look at your link and a further simular thread.I have changed what I can for example the config file, but somethings where your suppose to log in to to wordpress I cant do as it seem to conflict with silverstipe.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    Try renaming the .htaccess file in your root domain folder.

  5. elizzz
    Posted 4 years ago #

    Make sure that the site url and site path has been changed...

  6. hattendesign
    Posted 4 years ago #

    There's definitely a conflict with the .htaccess

    I'd start by adding RewriteBase /travelblog
    to your WP .htaccess file


    I suggest a work-around, instead of trying to fix your .htaccess

    install wordpress on a subdomain like http://travelblog.kevnolan.co.uk

    That's a fast, easy fix which would avoid conflicts.


  7. kevnolan
    Posted 4 years ago #

    that sounds promising i'llgive that a go hattendesign.

  8. kevnolan
    Posted 4 years ago #

    Hey man that had worked a treat and I've made a bit of progress.

    I can now access the default page of the blog:

    At one point I had the images worked but now they have disappeared again.

    My other issue is permalinks, if I know the standard links i can access some of the posts that I have made.

    And also accessing the dashboard for some reason I can not do that.
    so at the minute... http://codex.wordpress.org/Linking_Posts_Pages_and_Categories

    I cant change this without access to the dashboard.

  9. hattendesign
    Posted 4 years ago #

    The last piece of the puzzle..

    I think you did an export of the whole database and not just the posts so the settings of your new database where replaced also.

    Open your export file with a text editor and do a find/replace
    Find any instance of your old url. I'm assuming it looks like http://locahostsomethinr/ortother

    and replace it with http://www.travelblog.kevnolan.co.uk

    You can also do this by going directly into the database using phpmyadmin

  10. kevnolan
    Posted 4 years ago #

    Sorted, thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic