Support » Fixing WordPress » Moving site URL to root

  • Resolved sorcel

    (@sorcel)


    Hi – Although I have used WordPress a while – I have never moved around on the installation. I tried today and things are not working – so I have done a completely new installation and reinstalled my backup with updraftplus

    A bit about my setup:
    – My main site is called http://www.mainsite.no
    – WordPress is installed in http://www.mainsite.no/wordpress/
    – My wordpress URL in general settings is: http:/mainsite/wordpress
    – My site URL in general settings is: http://www.mainsite/wordpress

    I would like wordpress to be installed in http://www.mainsite/wordpress
    but I would like my site url to be http://www.mainsite

    I have tried making the changes in general settings – but this is apparantly not enough. What else do I need to do ?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Thread Starter sorcel

    (@sorcel)

    Thanks James Huff (@macmanx),

    I had seen this – my “problem” is the opposite. I have everything installed in a subdirectory example.com/wordpress – but I would like people to access pages via example.com

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    The documentation still applies, it’s for having WordPress in its own directory (like example.com/wordpress) but served from the root domain (like example.com).

    Thread Starter sorcel

    (@sorcel)

    First I tried like the article suggested:
    Method II (With URL change) – that is following the list for the steps I had not done previously
    Result Server error

    Second I tried like the article suggested:
    Method I (Without URL change) – that is Installing wordpress in root folder, moving EVERYTHING from root folder into subdirectory called wordpress and creating a .htaccess file in root folder
    Result: Server error

    I have no idea why I had these server errors. I only tested on my static home page (unfortunately) so I don’t know if I would have had the same error on other pages.

    Third I tried (short version because there was a lot of fiddling):
    Reinstalling WordPress and Backup, Copy Htaccess and index.php to root and making some changes
    Result: I could access things by going to mysite – but when the page came up it showed mysite/wordpress
    So I went in to general settings and left the wordpress site as mysite/wordpress and changed the site URL to mysite.

    Seems as if things are working now.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Moving site URL to root’ is closed to new replies.