Support » Fixing WordPress » Moving site, lost thumbnails for media library and front

  • Resolved suzbinky


    Site worked fine at xx/dev. Created new install of WP. Exported from dev, imported into new location. Same server, but at root level. Did find/replace for the wp-posts and the WP exported xml file from the wp-admin interface to change /dev/ to / . Posts are fine. Almost AOK. Seem to be some permissions issues where I cannot delete a couple of plugins, but can delete others.

    Biggest issue is that in wp-admin/media > library: – the thumbnails do NOT show up. If I click to open, wp-admin/media.php?attachment_id=2043&action=edit thumbnail still not there, nor can I edit the image – no screen to show how to edit the image – no image to be found in thumbnail area, but if I open the image by clicking on it:!prettyPhoto – the image is there smaller. If I click on the linked name of the image below it nothing shows but the next related image name linked. Popup window is there, but no image. Only the image names show up that link to the popup for pretty photo and a blank display.

    Can anyone help me figure out how to get the images in the library to talk to the features with thumbnails and popups? There are nearly 400 library items with 286 that are attached to posts in our portfolio.
    Talked to template developer. He thinks it’s a file permissions issue.

    Thank you. Hosting company cannot help. They barely are able to assist with domains. Stuck there for now, so moving not an option today.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Christine Rondeau


    Volunteer Forum Moderator

    Have you looked at this thread –

    I’ve had that happened to me and I poke around in the database. I can’t remember which table the images path are stored, but if you look in your db, you’ll probably find that the path to the images are still pointing to your dev server.

    Using software like filezilla – ftp your installation folder and change the permission for uploads folder –

    Thanks for quick replies.
    Did that, Cinghaman. Permissions are set to 755 on directories, 666 on files. The thread referenced by Christine wasn’t quite it. I did make the change in database. Went into PHPmy Admin – clicked on wp-posts, exported, deleted them all. Used Notepad to do find and replace for /dev/ to / and imported back into wp-posts. It worked for the larger version, just not featured or thumbnails. Is there another table that may need that same fix? I ran through the posts table and several posts – they all have the correct paths for images. The plug in referenced in that thread didn’t make sense to me. Tried it, cannot delete it from the wp-admin, but deactivated it successfully.

    try using this tool for your database migration (search and replace) on your main database

    it takes care of serialization as well and you wont need to manually replace any code on database

    upload the php file (from the link) to the xx/dev and run the file

    replace ur old url xx/dev to /

    Thank you, did that. All was taken care of except for the media library. Those images are there LARGE in posts, but for the generated thumbnails on the front end AND in the admin – they don’t work. “preview item is not available” when I go to the portfolio. Large images display just fine. I can add any of your ips so you can see. It’s tucked away for now. Still feels like a permissions issue – as if the php telling it to generate the thumbnails is unable to do what it should do since the images are there.

    Looking for a professional who may experience with this and can help me run through the DB with a solution. Would prefer to not have to reinstall 400 media files.

    Found my source, found my issue, solving it now with server owner. Thank you all.

    I’m having this now too. What was it?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Moving site, lost thumbnails for media library and front’ is closed to new replies.