Support » Fixing WordPress » Moving index to a separate folder

  • Alright, when I used B2 I had moved my index to my root folder, rather then having it sit in the B2 folder. Using instructions obtained from this site, I did the same with WP as well.
    Now I should mention that I had to do a TON of configurations on B2 to get everything working well, just editing a few lines (and inserting the new URL) doesn’t seem to cut it because everywhere I go I seem to run into new difficulties that have risen from this. I’ve been doing a lot of configuring -just on that- since last night, mostly in my admin files, but I’ll be one to admit that I’m not an expert in PHP and therefore whenever I edit something, I usually end up messing up something else… Fortunatly that hasn’t occured yet…
    Well, to cut the long story short -at the moment- there are two things I can’t firgure out how to fix in my site, that are a direct result of changing the location of my index file ( )
    1 – When you click on comments, and it takes you to Trackback, the URL that is given on the top is “” now the trackbacking itself works fine when using “” but it’s just getting that little /WP/ in there that seems to be the difficult task for me, I did go to the comments files, as well as the trackback files AS well as the template-functions file, but I can’t seem to find anywhere where I could -stick- that extra /wp/ in…
    2- In admin>templates the first box gives me this error
    ” Editing ../index.php
    Oops, no such file exists! Double check the name and try again, merci.”
    again, where should I edit, within the text files so that the file is redirected to the root folder…
    I’m thinking that perhaps I should document all of the changes that I’ve made, just for future reference; unless of course, you know of a place where all of this is documented. :o)

Viewing 5 replies - 1 through 5 (of 5 total)
  • Wait till help arrives 🙂 I just wanted to let you know that documenting whatever you did would be a great help to others.

    Gosh, I just noticed #5, I don’t know how I -ever- missed that. Now unless I’m really missing something again, I still don’t know how to work around Question 2.

    Scratch above- My problems doesn’t originate from perma-links, I’ve fixed that already… The trackback settings seem to be at fault (and I can’t seem change those in the admin option, I think I have to dig in the actual coding..) =/

    Note: With some editing in the template-functions.php I solved problem #1 and some others as well (lucky break), I’ll document it and post it ASAP. I’ll work on 2 later myself.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Moving index to a separate folder’ is closed to new replies.