Support » Installing WordPress » Moving hosts, some trouble, mod_rewrite missing?

  • Resolved davidjg



    Moving a WP installation to a new server. Database was moved without a problem, and files were uploaded. Now, I can log into the Admin section, and see all the posts from there. However, no styles are applied in the Admin section, and it’s not possible to see the site at all. PHP and MySQL versions meet the requirements, so is this consistent with the mod_rewrite module being missing?

    Extra info: Fancy permalinks were applied when the database was moved, but were turned off from Admin panel with no change.

    Thanks for any help you can give – this is driving me crazy!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Mark (podz)


    Support Maven

    A link will help, certainly with the styles issue.
    Tried changing themes ?

    It’s not the site theme that doesn’t work (whole site is down apart from when I can link to a definite file – e.g. wp-admin/index.php), it’s the admin style – which I believe is accessed via wp-admin.css?version= (or something similar). But the fact of the style isn’t the main problem, the whole site-not-working is the problem. The admin style is what leads me to believe mod_rewrite is missing, because from my (admittedly limited understanding), that’s what helps with the on-the-fly URLs and things…

    Mark (podz)


    Support Maven

    The admin style is
    mod rewrite has no effect on this because those files are always accessed relatively because the files there don’t move.

    I would check that all files have indeed uploaded and that none have a filesize of zero.

    All files are present and correct. Apologies, perhaps I could have been clearer describing the problem.

    Front end of the site isn’t working. At all. Back-end is, But non-dynamically-generated pages are fine (e.g. wp-admin/index.php, /post.php etc.). Thus, this leads me to think that the problem is somewhere with the dynamically generated URLs. The whole admin styles was just a symptom (as well as a problem, but one that I hope will fix itself when the main problem is fixed). And probably should have specified 1.5.2, not 2.0 – my mistake!

    From admin-header.php:
    <link rel="stylesheet" href="<?php echo get_settings('siteurl') ?>/wp-admin/wp-admin.css?version=<?php bloginfo('version'); ?>" type="text/css" />

    I’m assuming (and will defer to your greater experience if you say otherwise) that mod_rewrite deals with the dynamic URL generation with pages, and thus either isn’t on the server (not entirely sure as to their setup), or is configured incorrectly.

    Thanks for your help so far!

    Mark (podz)


    Support Maven

    The string of code there is php and has nothing to do with mod_rewrite (else it wouldn’t work on hosts without it).

    In your browser, go to
    Make that the url of your site but be sure the end is correct.

    Do you see a css file ?

    HTTP Error 403.2 – Forbidden: Read access is denied.

    The directory I’ve been given is script only though, plus the host has only enabled default.htm/defualt.php to be used for the index.

    Mark (podz)


    Support Maven

    WP directories are usually 755.
    Try that ?

    If that is not possible ….. talk to your host and maybe think about moving ?

    podz – I emailed them, and asked them to change permissions. Solved the problem of being able to see the site. The pretty permalinks was because they’re running IIS, not (as I was told), Apache…so they need ISAPI_rewrite

    The following links helped me work out IIS permission levels:
    Necessary file permissions
    CHMOD to IIS

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Moving hosts, some trouble, mod_rewrite missing?’ is closed to new replies.