WordPress.org

Forums

[resolved] moving from MS host to UNIX host - anything special to do? (7 posts)

  1. Ken Soszka
    Member
    Posted 5 years ago #

    Hi, I am moving my site from a microsoft hosting plan to a unix hosting plan, at a different hosting company. I have uploaded all of the files, and created a new DB and imported the existing DB to it. I edited the wp-config.php to match the new DB.

    Although I have not tried pointing an actual domain at the new copy of my site, it does not seem to be working when I use the temporary domain given to me by the hosting comany, with /directory/index.php added to it. I get a 500 error "The website cannot display the page - Most likely causes:
    •The website is under maintenance.
    •The website has a programming error."

    Should I be able to see it that way? There is a php-cgi-fcg1i.ini file in the root of my site. I think it is for running php on MS. Do I need a php-mod file or something for the unix?

    Thanks!

  2. First, remove the php-cgi-fcg1i.ini file. Next, you'll have to access the database and manually change the siteurl and home values to use the temporary domain. You can easily change them again at Settings/General in your admin panel before you point your domain to the new server.

  3. Ken Soszka
    Member
    Posted 5 years ago #

    Thanks, just did that but no luck. Same page error. I have permalinks turned on, would this affect anything?

  4. Ken Soszka
    Member
    Posted 5 years ago #

    Disregard my last reply - I had a typo in the wp-config.php. I am connecting now, and also pointed the real domain at it - BUT I get this error:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homepages/33/d331420110/htdocs/moneylinksonline/wp-content/plugins/custom-post-template/custom-post-templates.php on line 39

    This is line 39:

    private $tpl_meta_key;

  5. If you can access your admin panel, deactivate, delete, and reinstall the Custom Post Template plugin. If you can't access your admin panel, manually deactivate all of your plugins, then delete and reinstall it.

  6. Ken Soszka
    Member
    Posted 5 years ago #

    Well, turns out that the exact error is posted on the plugin page, in the FAQ section. It occurs if the host is running less than PHP 5. My new host has 4 by default, so I found some instructions from the host on adding a line to your .htaccess file, or creating one, the entry is "AddType x-mapp-php5 .php". This adds PHP 5 to the configuration. Now everything is fine. There were several other plugins that required PHP 5 as well. Thanks for all your help!

  7. You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic