Support » Fixing WordPress » moving databases

  • Resolved thaKing

    (@thaking)


    when i signed up for my hosting account (godaddy.com) they installed wordpress for me..that sounded great until i realized the database is stored in a virtual directory…thus i have no access to my tables if i need to modify them, etc…

    i contacted them and they said they’d be more than happy to move the tables to my mysql that is part of my account…all i need to do is “correctly map the connection string to the database” and all will be right..

    so my question is, how do i do that? is that something i do through wordpress or via phpmyadmin? if they move the database from the virtual directory to my database, will my blog still work? i don’t wanna start all over from the beginning if i can avoid it….

Viewing 4 replies - 1 through 4 (of 4 total)
  • u can fix it in ur file manager , get ur database info and insert them in your config.php file .

    i think in ur control panel in godaddy there is an option to get the connection string so u just need to fill out the info .

    Chaaban

    ok, i think i follow you…i go to my wp-config.php file and edit these fields with the new info:
    define('DB_NAME', 'name');
    define('DB_USER', 'user');
    define('DB_PASSWORD', 'pword');
    define('DB_HOST', 'host');

    i don’t currently see a connection string in my control panel, maybe that’s because i won’t see it until the database is moved over – do you think?

    In godaddy control panel -> go to database -> Mysql -> if there is a database u will be able to see it , now under action ther is 3 icons , click on the first icon .

    a page will pop up showing those info :

    //Connect To Database
    $hostname=”##DBSERVER##”;
    $username=”##DBUSER##”;
    $password=”your_password”;
    $dbname=”##DBNAME##”;

    so with those replace (name, user , pword , host) :

    define(‘DB_NAME’, ‘name’); <<== db name
    define(‘DB_USER’, ‘user’); <<== user name
    define(‘DB_PASSWORD’, ‘pword’); <<== password
    define(‘DB_HOST’, ‘host’); <<== host name

    ok, gotcha…that’s what i suspected…i don’t currently have a database under mysql so that’s why i didn’t see it…

    thanks for the help…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘moving databases’ is closed to new replies.